Bug #17538 Dropping a partition on a RANGE partition results in OOM error
Submitted: 18 Feb 2006 0:37 Modified: 18 Feb 2006 0:43
Reporter: Matthew Lord Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Partitions Severity:S1 (Critical)
Version:5.0.6-alpha OS:Linux (linux 2.4, 2.6)
Assigned to: CPU Architecture:Any

[18 Feb 2006 0:37] Matthew Lord
Description:
You cannot drop a partition on a table partitioned by RANGE.  Everything you get this error:
ERROR 1037 (HY001): Out of memory; restart server and try again (needed 12 bytes) 

How to repeat:
use test;

CREATE TABLE `t1` (
  `name` char(30) default NULL,
  `unixtime` bigint(20) unsigned default NULL,
  KEY `unixtime_idx` (`unixtime`),
  KEY `idx_name` (`name`(4))
) PARTITION BY RANGE ( unixtime) (PARTITION p1 VALUES LESS THAN (1136102400), PARTITION p2 VALUES LESS THAN (1167638400));

alter table t1 drop partition p2;
[18 Feb 2006 0:43] Jim Winstead
Doesn't happen in the latest 5.1 from bk. It is probably a duplicate of Bug #17169, which got fixed today.