Bug #17533 HP-UX 11.23 (IA64, 64-bit) Standard 5.0.18 Depot Install fails
Submitted: 17 Feb 2006 23:06 Modified: 21 Feb 2006 16:44
Reporter: Gary Rocklitz Email Updates:
Status: Closed Impact on me:
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.18 OS:HP/UX (HP-UX 11.23 (IA64, 64-bit))
Assigned to: CPU Architecture:Any

[17 Feb 2006 23:06] Gary Rocklitz
The depot file passes all HP's checks... no dependancies are found... looks like the depot belongs to the right machine... HP's swinstall installs the depot.

# tcltk                                 8.4.11         

# tiff                                  3.6.1          
# wget                                  1.9.1          
# xpm                                   3.4k           
# zlib                                  1.2.3          
with gcc installed in /usr/local/bin
% gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.23
Configured with: ../gcc/configure 
Thread model: single
gcc version 4.0.2

and an alternate perl in /usr/local/bin
% perl -v

This is perl, v5.8.6 built for IA64.ARCHREV_0

Copyright 1987-2004, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

All of which suggests to me that... whoever built your 
     HP-UX 11.23 (IA64, 64-bit)	Standard	5.0.18	
     * Did it on a non-standard machine...
     * Did it with non-standard perl
     * Did it with non-standard compilers.

Note: I have not tried the depot from the porting archive at:

How to repeat:

Get past...
./bin/my_print_defaults: Syntax error at line 10 : `)' is not expected.
Neither host 'suprdome' nor 'localhost' could be looked up with

switch to ./bin
Get something other than:
./my_print_defaults: Syntax error at line 10 : `)' is not expected.

Get something other than:
./resolveip: ^?ELF^B^B^A^A^A^B2^A@ËP@^DC:  not found.
./resolveip: X:  not found.
./resolveip: ^D^A^E@^C^V:  not found.
./resolveip: ^A^H^F^C:  not found.
./resolveip: ^Q^D^Cäç^A^D^D^Cäèè^H:  not found.
./resolveip: °^H^N:^P^Y:  not found.
./resolveip: ÉàX^NW^R^R@^BÉà^A ^Nm^Q^\:  not found.
./resolveip: X^H^C^D½p@½p..^A^B^D^C:  not found.
./resolveip[38]: ^NÀ^Q^T:  not found.
./resolveip[38]: °^NÖ^R^R@^Ac^P^KÀ^Nä^R^R@^A±^C^P^Nì^R^R@^B^]:  not found.
./resolveip[38]: ^O^H^R^R@^B^A^P^E:  not found.
./resolveip[38]: e^N¡@^Jg^N¨^R^R@^B¶@^C^P^N¹^R^R@^A£;^C0^Nü^R^R@^Bª ^C^O^Z@:  not found.
./resolveip[39]: !P ^O2^R^R@^A¬Ð ^O9@^Wi ^O@^Q^^:  not found.
./resolveip[39]: Äç^Oe^R^R@^Aá^O}^Q^\:  not found.
./resolveip[39]: ø^H^OÈ^R^R@^B:  not found.
./resolveip[39]: ×zHÑ^T^A^A£®^A^P¬^G:  not found.
./resolveip[39]: ÓSãò½÷«çèéæ6^Aýáa^A^R^VYÒ^A^W^A^M^A^V^A^Kì^A^S^A^QÿÈêë^KͧÔømE:  not found.
./resolveip[39]: 0v!pg}VrD:: Cannot find or open the file.
./resolveip[42]: Syntax error at line 42 : `(' is not expected

Suggested fix:
Either it's a personal problem... and/or I'm missing some needed libraries or updates... 

Or (more likely) this code wasn't compiled on an HP-UX 11i v2 (HP-UX 11.23) computer.  Perhaps it was compiled on an HP-UX 11i v1 (HP-UX 11.11) PA-RISC 2... not Itanium... computer?

I'd try re-compiling on a superdome... 
or some other HP-UX 11i v2 (HP-UX 11.23) computer.

It may be possible to get HP to help...
I'm willing to help, but I've never made a depot file.

[19 Feb 2006 12:50] Valeriy Kravchuk
Thank you for a problem report. Sorry, but I do not understand your problem. You have (successfully) installed http://dev.mysql.com/get/Downloads/MySQL-5.0/mysql-standard-5.0.18-hpux11.23-ia64-64bit.de..., and what happened then? What commands you performed, what had you got and what you expected to get? Please, clarify.
[19 Feb 2006 15:30] Gary Rocklitz
Looks like the bug submittal program severely truncated this bug.
The depot checks OK... but I believe the depot was not compiled on a standard HPUX 11i 11.23 machine.
The perl bin files are using a non-standard (for HP) perl (/usr/contrib/bin/perl ranther than the HPUX standard usr/bin/perl or the open source install usr/local/bin/perl) and the binary programs look to be built for a wrong machine as well... yield the results seen in "how to repeat this bug".

I've added paths to gcc libraries on the guess that this might have been built using gcc rather than hp's cc... that does not work either. 

I've re-perled the bin scripts to an installed version of perl... but don't get very far since the config script and the binaries show the results seen in "how to repeat this bug".  It might be me, but I'm guessing this depot wasn't built on an HP 11i platform... the binaries ry to execute, but return gibberish.

Other than more detail, the original bug submittal had a bunch on what's on my machine... it's a fairly vanilla HP 11i  (11.23) Superdome... with hp compilers installed and gcc and a more up to date perl alternately also available.
[20 Feb 2006 9:28] Ay Nakamura
I also failed to install MySQL 5.0.18 using depot package from http://mirror.mysql-partners-jp.biz/Downloads/MySQL-5.0/mysql-max-5.0.18-hpux11.23-ia64-64....

'swinstall' worked gracefully. However, I couldn't invoke "./scripts/mysql_install_db".  
Then I found no body, even a owner-user, had a 'write' permission for all directories and files under /usr/local/mysql. 

To avoid this problem, I did as follows;
# cd /usr/local/mysql
# chmod u+w *
# chmod 755 ./bin/*
# chmod 750 ./data/mysql ./data/test
# chmod 644 ./docs/*
# chmod -R u+w include lib man mysql-test scripts share sql-bench support-files tests

I guess something wrong with Depot packages for HP-UX 11.23 (IA64).
Please check.
[21 Feb 2006 16:44] Gary Rocklitz
Turned out the binarys not working was a personal problem...  apparently my gunzip was corrupting.

I fixed the /usr/contrib/bin/perl problem with the following script:

#!/bin/csh -f
# #!/bin/csh -f -v -x
# -------------------------------------------------------------------------
# Script to change perl locale
# To use:
#          type reperl
# -------------------------------------------------------------------------

echo 'Fix perl in      .'

set files = `grep -c /usr/contrib/bin/perl * | awk 'BEGIN { FS = ":" } ; {if ($2 > 0 ) print $1; }'`

foreach i ($files)
   cp $i junk.tmp
   sed -e 's/\/usr\/contrib\/bin\/perl/\/usr\/local\/bin\/perl/' junk.tmp > $i
   echo 'changed file: '$i
rm junk.tmp