Bug #17481 mysqlslap not using designated database/schema
Submitted: 16 Feb 2006 16:11 Modified: 11 Apr 2006 22:37
Reporter: Robin Schumacher Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.1.6 OS:Linux (Fedora core 4)
Assigned to: Miguel Solorzano CPU Architecture:Any

[16 Feb 2006 16:11] Robin Schumacher
Description:
mysqlslap not using the designated schema/database

How to repeat:
Run: /usr/local/mysql516/bin/mysqlslap -a -c 10 -e --create-schema=myschema myisam -x 5 -y 5 -i 1000 -pword -P3306 -socket=/usr/local/mysql516/mysql5.sock -uroot

Get errors stating "Unknown database 'mysqlslap'"

If designated schema exists, it drops the schema and then issues the same errors.
[17 Mar 2006 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[11 Apr 2006 20:52] Magnus BlÄudd
Duplicate of bug#16171
[11 Apr 2006 22:37] Robin Schumacher
Tried using suggested spelling fix with new 5.1.7 build and getting error "Unknown option '-o'

/usr/local/mysql517/bin/mysqlslap -a -c 10 -e myisam --create-schema=myschema -x 5 -y 5 -i 1000 -pword -P3306 -socket=/usr/local/mysql517/mysql5.sock-uroot