Bug #1744 mysql wont install using 2.6 kernel and glibc with native posix threading libra
Submitted: 3 Nov 2003 19:55 Modified: 5 Nov 2003 4:15
Reporter: [ name withheld ] Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.16 OS:x86 Linux, 2.6 kernel
Assigned to: CPU Architecture:Any

[3 Nov 2003 19:55] [ name withheld ]
Mysql won't install when the native posix threading library is used, as the configure script is hardcoded to require LinuxThreads on linux. Thus, it cannot be used when running a development kernel with glibc compiled with nptl support.
The configure script output is as follows:
checking "LinuxThreads"... "Not found"
configure: error: This is a linux system and Linuxthreads was not
found. On linux Linuxthreads should be used.  Please install Linuxthreads
(or a new glibc) and try again.  See the Installation chapter in the
Reference Manual for more information.

Note that i have tried using '--with-pthread' to override the LinuxThreads on the configure script, but the same thing happened.

How to repeat:
Install a 2.6 series kernel, and recompile glibc for it with nptl support. Attempt to install mysql.

Suggested fix:
I suspect that this can be fixed in the configure script, by not requiring LinuxThreads on linux.
[5 Nov 2003 4:15] Alexander Keremidarski
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

What Linux distribution you are using and how did you compiled MySQL?

I am able to link mysqld against NPTL on RedHat 9 with both RedHat provided kernel and 2.6.0-test9, but this is probably because RedHat sets NPTL to represent themselves as LinuxThreads with regard of configure scripts.

Did you tried --with-named-thread-libs= option?
[5 Nov 2003 15:14] [ name withheld ]
For the record, I'm using Gentoo linux, and had tried both the Gentoo ebuild script, and manually from the mysql source.
The hint about --with-named-thread-libs= worked, thanks for the help.