Bug #1742 MySQLCC crashes when started in Win98
Submitted: 3 Nov 2003 11:27 Modified: 3 Nov 2003 13:43
Reporter: [ name withheld ] Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQLCC Severity:S3 (Non-critical)
Version:mysqlcc-0.9.3-win32 OS:Microsoft Windows (Windows 98)
Assigned to: CPU Architecture:Any

[3 Nov 2003 11:27] [ name withheld ]
Description:
Attempting to start MySQLCC 0.9.3 in Win98 results in an error (see below) and program termination. Tried restarting PC (didn't fix), tried uninstalling, re-downloading and reinstalling, but error remains. Problem appeared several days after upgrading from version 0.9.2. When problem occured, I also had the Win98 ODBC connection editor open, as well as CodeCharge RAD software, which was generating PHP to interact with MySQL. 

MYSQLCC caused an invalid page fault in
module QT-MT312.DLL at 017f:39ee1141.
Registers:
EAX=0074f740 CS=017f EIP=39ee1141 EFLGS=00010202
EBX=00000000 SS=0187 ESP=0074f714 EBP=0074f724
ECX=00610063 DS=0187 ESI=0074f730 FS=5497
EDX=0000003d ES=0187 EDI=0087ce50 GS=0000
Bytes at CS:EIP:
8b 11 ff 52 20 8b 45 08 5e 5d c2 08 00 55 8b ec 
Stack dump:
0074f738 0074f740 0074f730 004beddc 0074f748 004033d5 0074f738 0000003d 008b26c0 008ae760 008a6550 008a4ef0 0074f7c0 0074f7c0 00403305 00000000

Couldn't find anything about this searching current bug reports. What else should I try? 

Luke 
ldeese@obie.com

How to repeat:
I can't get it running long enough to try!
[3 Nov 2003 13:17] [ name withheld ]
Further testing showed that this was triggered by adding a password to the root user from the Control Center. Deleting the password from the MySQL command line and calling FLUSH PRIVILEGES allowed the Control Center to start.

I am fairly new to MySQL/MySQLCC, but I am surprised that the Control Center did not know to use the password it had just created. Is this expected/intentional behavior, or a bug?
[3 Nov 2003 13:43] Dean Ellis
This appears to be a duplicate of bug 1622 (MySQLCC crashing when using invalid login).

MySQLCC only knows to use the login you give it.  It should not crash, of course, but it does not reconfigure itself automatically.

Thank you
[3 Nov 2003 13:50] Ross Carver
This is a problem with mysqlcc failing  to handle gracefully the error from mysql caused by bad authentication.  Make sure that you have created the correct user:host authentication (especially when using mysqlcc from a host different than the host which mysql resides on).  Second, don't choose to connect automatically upon startup to a connection unless you have verified manually via mysqlcc that it works(ie mysqlcc doesn't crash).

Hope  this helps.

~Ross Carver
recarv@comcast.net