Bug #17324 myodbc testing connection while setting DSN
Submitted: 11 Feb 2006 14:48 Modified: 1 Oct 2007 14:38
Reporter: Marco Banfi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:3.51.12 OS:Microsoft Windows (windows XP SP2)
Assigned to: CPU Architecture:Any

[11 Feb 2006 14:48] Marco Banfi
Description:
MYSQL 4.0.24,but I don't think that really matters.
Hi,this is not a serious one,no,really.

Once I made a little mistake, I wrote the database name with a space in front.
Testing while setting a System DSN gave me an "OK". Trying to connect with any program gave me " databasename"  not found.

Cheers. Marco.

How to repeat:
Try to create a DSN,insert an existing catalog with a space in front of it,with right credentials. Try Test Connnection,then try to use the created DSN from any language.

Suggested fix:
Stop trimming spaces from the front of the catalog name,or trim spaces while saving the DSN info. I don't know which one is the best solution.
[12 Feb 2006 9:51] Valeriy Kravchuk
Thank you for a bug report. Verified just as described on XP.
[14 Aug 2007 19:00] Susanne Ebrecht
Hello,

sorry, but I can't reproduce the error.

Did you always write the database name in backticks (` databasename`)?

Please try again with MySQL Server 5.1 and MyODBC 3.51.19.

Regards,

Susanne
[14 Sep 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".