Bug #16801 Excel gives "Unable to connect to data source. Reason: Access denied"
Submitted: 26 Jan 2006 10:23 Modified: 31 Jul 2007 6:36
Reporter: Trevor Williams Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:odbc 3.51.12 OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[26 Jan 2006 10:23] Trevor Williams
Description:
I installed the new MySQL 5.0.16-nt and the odbc driver using mysql-connector-odbc-3.51.12-win32.msi. The MySQl Administrator tools access the database without a problem. When installing the odbc driver, if I click on the databases drop down at the bottom it hangs the installation. If I test the link without using the drop down databases list, it connects succesfully, but then hands when I try to press any other button or tab. If I don't test the link, the System DSN is created. I have tried setting up the odbc connector on 3 PCs but the same happens. I think this might be part of my problem.

I then tried to use the DSN to open Data Import in Excel and when I test the connection I got the error "Test connection failed because of an error in initializing provide. Catastrophic failure". If I don't test and click OK, I get the error "Unable to connect to data source. Reason Access denied ....." 

I am using Excel veriosn2002 and Excel version 2003 on differnet PCs. I tried with a remote and a local database on the same network.

How to repeat:
Install mysql-connector-odbc-3.51.12-win32.msi and MySQL 5.0.16-nt and try access the data using the "import data" or "new database query" tools in Excel
[26 Jan 2006 15:12] Miguel Solorzano
Excel importing data with MyODBC

Attachment: bug16801.PNG (image/x-png, text), 42.24 KiB.

[26 Jan 2006 15:15] Miguel Solorzano
I was unable to repeat this issue with Connector 3.51.12 and current server
release 5.0.18 with Excel 2003.

i attached a picture showing Excel importing data.
[31 Jul 2007 6:36] Tonci Grgin
Trevor, these are two completely different problems serious being the later one (import to Excel). For that part, this is duplicate of Bug#16653 (Bug#24580 contains some info too). See the discussion there please.
[7 Sep 2007 12:10] Susanne Ebrecht
Hi Trevor,

please try this again with the newest version of MyODBC (3.51.19) and a newer MySQL Server version. Let us now, if the error is still occur.

Regards,

Susanne