Bug #16675 Administrator does not handle properly multiple config files
Submitted: 20 Jan 2006 15:46 Modified: 29 Aug 2006 11:52
Reporter: [ name withheld ] Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.1.5 OS:Microsoft Windows (Windows XP)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: Server Configuration

[20 Jan 2006 15:46] [ name withheld ]
Description:
With 2 instances of mysql server running, on different ports, the administrator application does not allow the user to correctly load the appropriate config file for the server on the port specified on login. Hence, if service 1 is on port 3306, service 2 on 9876, for some reason, the config that appears when logging to 3306 is that of 9876, and any changes made to the port do not apply to the 3306 sevice (on which we are logged in) but to the 9876 service.

How to repeat:
I have 2 instances of mysql server running. One is 4.1, one is 5.0.

I want both instances to be on different ports. So one is on 3306, and the other on 9876.

When I installed mysql 5.0 (4.1 already installed), I 'think' I installed the new service on port 3306.

Now, when I log in to the administrator to the mysql 5 dtabase, the config I get for the port number is the config of the mysql 4 database, and when I apply the change, it gets applied to the mysql 4 database, not the mysql 5 dtabase. The config file names confirm this. This has a consequence that I cannot alter the port of the mysql 5 service.

Suggested fix:
Load the correct configuration file path.
[26 Jan 2006 20:46] Jorge del Conde
Thanks for your bug report.  I was able to reproduce this using the latest MA version
[29 Aug 2006 11:52] Mike Lischke
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/.

The point is you can only connect to a running instance if you just use the normal login. So if your 4.1 server is running and 5.0 is not (only one can run at a given port) then you connect to 4.1 not 5.0. Consequently, all changes you make are applied to 4.1, not 5.0. For configuring the 5.0 server use the service maintenance mode by holding the ctrl key while you are in the login dialog. The "Cancel" Button will change to "Skip" and allows to start without an active connection (i.e. it does not matter if a server is running). Now you get all installed instances listed and you can change their settings, including the port. Use MA also to start the service once you fixed it.