Bug #1660 Mismatching database name
Submitted: 25 Oct 2003 4:34 Modified: 25 Oct 2003 6:43
Reporter: Juraj Lonc Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S2 (Serious)
Version:3.1.0 alpha OS:Microsoft Windows (WinXP)
Assigned to: CPU Architecture:Any

[25 Oct 2003 4:34] Juraj Lonc
Description:
Windows XP
MySQL Server 4.1.0 alpha
MySQL Connector/J 3.1.0 alpha
Java 2 SDK 1.4.1_02
Apache Tomcat 5.0

i'm trying to connect to sql:

conn=DriverManager.getConnection("jdbc:mysql://localhost:3306/iportal?user=duro&password=bambulka");

or

conn=DriverManager.getConnection("jdbc:mysql://localhost:3306/iportal","duro","bambulka");

but, it returns an error: 
java.sql.SQLException: Communication failure during handshake. Message from server: "Unknown database 'ipor'"

(so, i'm requesting 'iportal' database, but it says i'm trying to connect to non-existing 'ipor' database)

How to repeat:
repeats permanently
[25 Oct 2003 6:43] Mark Matthews
This has been fixed for quite some time (and is a duplicate of a few other bug #'s in this system). Please checkout a nightly snapshot from http://downloads.mysql.com/snapshots.php