Bug #16491 libstdc++.so.6(GLIBCXX_3.4.4) is needed by mysql-administrator-1.1.6-1.i386
Submitted: 13 Jan 2006 19:03 Modified: 28 Mar 2006 20:23
Reporter: joe byers Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:1.1.6 OS:Linux (Linux)
Assigned to: Alfredo Kojima CPU Architecture:Any

[13 Jan 2006 19:03] joe byers
Description:
This is similar to MYsql Workbench bug#15218

I am trying to install the latest version of mysqladministrator and mysqlquerybrowser and get this failed dependenciec
libstdc++.so.6(GLIBCXX_3.4.4) is needed by mysql-administrator-1.1.6-1.i386
libstdc++.so.6(GLIBCXX_3.4.4) is needed by mysql-query-browser-1.1.18-1.i386

My OS is RedHat EL4 with beta's installed
libgcc-3.4.5-2
libgcj-3.4.5-2
libgcj-devel-3.4.5-2
libgnat-3.4.5-2
libstdc++-3.4.5-2
libstdc++-devel-3.4.5-2
libobjc-3.4.5-2
libf2c-3.4.5-2
cpp-3.4.5-2
gcc-3.4.5-2
gcc-c++-3.4.5-2
gcc-g77-3.4.5-2
gcc-gnat-3.4.5-2
gcc-java-3.4.5-2
gcc-objc-3.4.5-2

all other glib's are the latest versions.

Note on the Redhat OS the gcc 3.4.4 and 3.4.5 directories are softlinked to 3.4.3 where the updated versions were installed.  Do these softlinks interfere with the installation of mysqladministrator or querybrowser?

thank you

How to repeat:
have a basic REL4 system running with mysql and try to install administrator or querybrowser
[17 Jan 2006 14:45] Jay Fougere
I am having the exact same problem with CentOS 4.2. I assume the problem would extend itself to any of the the other repackaged distros as well.
[18 Jan 2006 14:49] [ name withheld ]
same problem for me on Redhat AS 4 with mysql-administrator-1.1.6-1.i386.rpm. 
I have the library but it seams not enough...
#ls -l /usr/lib/libstdc++.so.6
lrwxrwxrwx  1 root root 18 nov 16 17:27 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.3

#rpm -i mysql-administrator-1.1.6-1.i386.rpm
erreur: D├ępendances requises:
        libstdc++.so.6(GLIBCXX_3.4.4) est n├ęcessaire pour mysql-administrator-1.1.6-1.i386

it's also the same problem for mysql-query-browser-1.1.18-1.i386
[20 Jan 2006 12:39] xie chengyu
i have the same problem .

i install all of the rpms named like glib*.rpm in .but problem still exits
[23 Jan 2006 22:00] Phil Hoppes
I have the same problem.  One new wrinkle, I found the following rpm

gnat-gcc-4.0.2-RHEL4.i386.rpm which installs correctly for redhat EL4 (make sure you have a user gnat).  This installs GLIBCXX_3.4.4.  and now mysql-administrator-1.1.6-1.i386.rpm and mysql-query-browser-1.1.18-1.i386.rpm both install.  But when you try to execute them you get the following message:

/usr/bin/mysql-query-browser-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by /usr/bin/mysql-query-browser-bin)

but when I got to /usr/lib and do a ls -al on /usr/lib/libstdc++.so.6 I get:
24][phoppes@overgaard ~]$ ls -al /usr/lib/libstdc++.so.6
lrwxrwxrwx  1 root root 18 Jan 19 09:00 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.3*

So there is a valid version of libstdc++.so.6 installed as ls -al libstdc++.so.6.0.3 gives :

26][phoppes@overgaard ~]$ ls -al /usr/lib/libstdc++.so.6.0.3
-rwxr-xr-x  1 root root 806176 Dec 14  2004 /usr/lib/libstdc++.so.6.0.3*

So I'm pointing to a valid library object.  How does one fix this?????
[26 Jan 2006 22:12] Jorge del Conde
I was able to reproduce this under a fully patched EL4 machine
[27 Jan 2006 14:58] Jay Fougere
I found a solution that worked for me :) 

Basically I found SRPMS for the missing dependencies and rebuilt them. This took a couple of hours on a P4 2.4Ghz w/1.5Gb RAM to build these packages.

I was going to try downloading the binary rpms for these packages, however I had problems with dependencies so rebuilding packages from source seemed like the best route to go to me.

Before you go any further, let me also state that I am using packages on my system from the following repositories: 
http://kde-redhat.sourceforge.net
http://dag.wieers.com/home-made/apt/
I do not believe that either of those repos introduce packages that assist in this procedure, however if you have missing dependencies other than those listed, you may check there.

I downloaded the src.rpm for each of the 4 following fedora core 3+4 packages:

http://fedoraproject.org/pre-extras/3/SRPMS/repodata/repoview/libsigc++20-0-2.0.6-1.html
http://fedoraproject.org/pre-extras/3/SRPMS/repodata/repoview/glibmm24-0-2.4.7-1.html
http://fedoraproject.org/pre-extras/3/SRPMS/repodata/repoview/gtkmm24-0-2.4.11-1.html
ftp://ftp.linux.ncsu.edu/pub/fedora/linux/core/4/SRPMS/gtkhtml3-3.6.2-1.src.rpm

I did a typical:

rpmbuild --rebuild package.src.rpm 
cd /usr/src/redhat/RPMS/i386 && rpm -Uvh package*.rpm 

in this order: 

1). libsigc++ 
2). glibmm24
3). gtkmm24
4). gtkhtml3

Note: Resulting RPMS are package, package-debuginfo, package-devel for all 4 packages. I installed all of them, though I think the debuginfo packages are optional. You are going to want to install the -devel packages for sure though :)

Note: If any of the packages give errors about missing packages (libgnomeprintui22 and libgnomeprint22 for gtkhtml3 gave me fits) be sure that you have the -devel package installed for them. I went round and round with gtkhtml3, knowing that I had the correct packages installed for which it was throwing errors (libgnomeprintui22 and libgnomeprint22) when what I needed was the -devel packages for those libraries (libgnomeprintui22-devel and libgnomeprint22-devel).

I then rebuilt RPMS from the src.rpms from dev.mysql.com for the gui tools (administrator, query-browser) as the prebuilt rpms still gave the following error when trying to install or run:

libstdc++.so.6(GLIBCXX_3.4.4) is needed by mysql-administrator-1.1.6-1.i386

rpmbuild --rebuild mysql-query-browser-1.1.18-1.src.rpm
cd /usr/src/redhat/RPMS/i386 && rpm -Uvh mysql-query-browser*.rpm

and 

rpmbuild --rebuild mysql-administrator-1.1.6-1.src.rpm
cd /usr/src/redhat/RPMS/i386 && rpm -Uvh mysql-administrator*.rpm

And all is well now :)

Please keep in mind that I am not a package maintainer and your mileage may vary.

Use at your own risk. I make no claims as to suitability for any purpose. Should your spouse leave you and move to Argentina or your toaster blow up, I take no responsibility :)
[16 Feb 2006 20:28] [ name withheld ]
Same probme as above re GLIBCXX_3.4.4 when trying mysql-admin and mysql-query-browser on RHEL 4.2.  I tried the rpms, srpms, and tar.gz and had problems with all of them.

First I tried the fix mentioned at
http://blog.arabx.com.au/?p=109 
using ibsigc++20-2.0.11-1.src.rpm but that didn't work.

Then I tried the suggestions by Jay Fougere but I was running into to many dependancy problems and just gave up for now.

Andrew
[1 Mar 2006 17:48] Charles Norton
I am having the same problem on Red Hat EL 3 WS:

[root@steamboy mysql]# rpm -i mysql-administrator-1.1.6-1.i386.rpm
error: Failed dependencies:
        libc.so.6(GLIBC_2.3.4) is needed by mysql-administrator-1.1.6-1
        libstdc++.so.6(GLIBCXX_3.4) is needed by mysql-administrator-1.1.6-1
        libstdc++.so.6(GLIBCXX_3.4.4) is needed by mysql-administrator-1.1.6-1
[root@steamboy mysql]#
[28 Mar 2006 18:16] Alfredo Kojima
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at 
http://www.mysql.com/downloads/

Additional info:

A new build has been added for RHEL4. It doesn't show up in the downloads page yet, but it can be downloaded from ftp://ftp.mysql.com/pub/mysql/download/mysql-administrator-1.1.6-1.rhel4.i386.rpm

That package should work with similar distributions (CentOS and others that use the same glibc version).
[28 Mar 2006 20:23] joe byers
Now what about mysql query browser 1.1.18
 failed dependencies libstdc++.so.6(GLIBCXX_3.4.4) is needed

Thanks for all the good work!

Joe
[1 May 2006 17:00] Wayne Betts
This ticket seems to have been closed without a solution for mysql-query-browser (trying to install 1.1.18).  It has significant dependency problems when installing on RHEL4 and its rebuilds, as reported within this thread, but now the thread is closed.  Any help?

The suggested download location is empty, and the latest rpm version still has the problem of failing to install because of a missing dependency on libstdc++.so.6(GLIBCXX_3.4.4)
[1 May 2006 20:10] Alfredo Kojima
A new version of Query Browser and Administrator will be released shortly, including binaries specific for RHEL4 for both applications.
[7 May 2006 22:02] Shoibal Chakravarty
I tried what Jay Fougere did.  When I rebuild the .rpm from the src.rpms I get the following 

myx_util_functions.c: In function `strlist_g_append_or_replace':
myx_util_functions.c:1720: warning: passing arg 1 of `strlist_g_indexof' from incompatible pointer type
myx_util_functions.c: In function `utf8_str_trim':
myx_util_functions.c:610: warning: statement with no effect

(maybe this not too bad:)
followed by 

In file included from myx_exporter.c:20:
../include/myx_public_interface.h:24:19: mysql.h: No such file or directory
In file included from myx_exporter.c:20:
../include/myx_public_interface.h:107: error: syntax error before '*' token
../include/myx_public_interface.h:668: error: syntax error before "MYSQL"

And then everything goes kaput without mysql.h. I couldn't find a mysql.h anywhere in the source distribution!  Can anybody help with this???
[7 May 2006 22:24] Shoibal Chakravarty
Forgot to add:

OS: RHEL4 (i386)
C: gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)
[8 May 2006 14:41] Alfredo Kojima
You need to have MySQL headers/client library installed (the package named MySQL-devel). Note that you need the client libraries for MySQL 5.0
[9 May 2006 13:43] Shoibal Chakravarty
Thanks, Alfredo.  the query browser runs quite well except for this warning that I get when it starts. 

................................
(mysql-query-browser:3356): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(mysql-query-browser:3356): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(mysql-query-browser:3356): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(mysql-query-browser:3356): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(mysql-query-browser:3356): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'
.........................................................

The souce compiled with the error - cant find -lgtk-x11-2.0 despite the fact that I have it.  What needs to be updated?

Thanks.