Bug #16480 Symbolic links to databases aren't working
Submitted: 13 Jan 2006 13:37 Modified: 13 Jan 2006 13:54
Reporter: Name Withheld Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:4.1.16 OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[13 Jan 2006 13:37] Name Withheld
Description:
On Windows, symbolic links to databases (i.e. ".sym files") stopped working in MySQL 4.1.15.

How to repeat:
In MySQL 4.1.15 or 4.1.16, boot mysqld.  It doesn't matter whether you use the the "--symbolic-links" option.

Execute "SHOW VARIABLES LIKE 'have_symlink';".

It returns "NO".  And in fact, symbolic links don't work.  For example:  if there are .sym files in the data folder, the corresponding databases aren't listed by "SHOW DATABASES;".

(In MySQL 4.1.14 and previous, that same query returns "YES"; and symbolic links work as expected.)
[13 Jan 2006 13:54] MySQL Verification Team
Thank you for the bug report. Duplicate of bug:

http://bugs.mysql.com/bug.php?id=14960