Bug #1602 Could not load the setup or translator library
Submitted: 19 Oct 2003 20:15 Modified: 22 Jul 2004 3:45
Reporter: Wizard of Oz Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.06 OS:Microsoft Windows (Windows NT4)
Assigned to:

[19 Oct 2003 20:15] Wizard of Oz
Description:
I installed the MySQL ODBC driver on Windows NT4 with SP6a installed. When I try to setup a System DSN then I get the following error messages:

The setup routines for the MySQL ODBC 3.51 Driver ODBC driver could not be loaded due to system error code 126.

... and then

Could not load the setup or translator library.

I did look at the KB article and installed the latest version of the MDAC (2.8), rebooted and the problem persists. Please note that I am not requesting support, the proposed solution just does not seem to work.

The ODBC driver works just fine on Win2k and higher.

How to repeat:
Install the ODBC driver on Windows NT
[4 Dec 2003 9:53] Miguel Solorzano
I don't have NT 4 for to make this test, then I have limited for to search
a possible cause for, and, I found that this issue isn't limited only to
MyODBC driver should happen also with anothers ODBC drivers. The explanation
for this issue and possible solution for you can find at:

http://support.microsoft.com/default.aspx?scid=kb;en-us;260558
[4 Dec 2003 10:12] Wizard of Oz
Dear Miguel,

Thank you for your efforts, the referenced article at Microsoft (KB260558) unfortunately does not solve the problem.

I am quite certain that the MDAC installation is correct. It was just verified with a special utility called "Component Checker" which you can download from http://www.microsoft.com/downloads/details.aspx?FamilyId=8F0A8DF6-4A21-4B43-BF53-14332EF09.... According to this tool the MDAC installation is 100% OK, yet the problem with the MySQL ODBC driver remains.

Note that this is a machine with hardly any software running on it, a clean NT4 installation with MDAC 2.8 installed.

There are no problems with a SQL ODBC driver, only the MySQL doesn't work.

This is quite a shame since we can't use MySQL here.

Best Regards,

Ingmar Koecher.
[22 Jul 2004 3:45] Timothy Smith
Unfortunately, we can't repeat this problem to figure out what is wrong.  This issue has been stalled for eight months now, so I'm setting it to "Can't Repeat".  If any further information is available, I would be glad to hear of it.

With apologies,

Timothy
[3 Aug 2004 2:09] Chris Jeske
I've had this problem twice now.  Running the same setup as you, NT 4.0 with SP6 and latest MyODBC driver.  Doublechecked everything, all the paths are correct everywhere, registry is fine, latest version of MDAC (I just reverted because I like 2.7 better than 2.8) etc.. 

Locate a copy of ctl3d32.dll and place it in your \winnt\system32 directory and all should be well.  It seems Windows has a problem loading the ODBC dlls without that file.

Best regards,

Chris Jeske
[13 Aug 2004 21:25] Chris Shaw
I have been struggling to find a solution for this problem. I have a number of older PC's running NT4 and I am in the process of migrating from MsAccess to MySQL. I have the same problem and cannot setup MyODBC on any of them. The newest version 3.51.9 does give the following error during installation: 

"Error 1918. Error installingODBC driver. MySQL 3.51 Driver, ODBC error 13: Could not load the setup or translator library. Verify that the file MySQL ODBC Driver exists and that you can access it."
[10 Sep 2004 10:23] Alessio Gordini
Hi Chris Shaw,
I had the same problem as yours, (i.e. during the installation of MyODBC driver 3.51 on a fresh new NT4.0+SP6a+MDAC2.8 machine the error 1918 dialog box was shown), and solved it just adding ctl3d32.dll, right as Chris Jeske suggested. Thanks Chris J.!!
Hope it helps,
Alessio
[29 Sep 2004 8:58] Heino Backhaus
I had the same Problem (error 1918 an so on). The solution was to place a copy of "ntctl3d.dll" under systemroot\system32 and renamed it to "ctl3d32.dll".
The ntctl3d.dll should be available on every WinNT. So there's no need to copy it from another machine compromising the newly and clean installed WinNT.

Have Fun
 H. Backhaus
[5 Jan 2005 8:17] just ali
I just know what't the problem is ,it is just a user permission problem.Please use the system default administrator user to install your odbc
[11 Jan 2005 18:14] Ivo Valente
I use IIS6 webserver and a mysql database, I had the mysql odbc connector installed, version 3.51.06, and decided to upgrade to version 3.51.10, for I am trying to find the source to an apparent memory leak associated with something that gets called by IIS.
I forgot to stop IIS and did not uninstall the previous version, and used the MSI instalation package for the myodbc driver, at the end of the instalation I was asked to restart my windows 2003 web edition server, which I did. When the system came up I could connect to the mysql database in any ASP page, even though I could setup a OBDC connection and test it succesfully. 
Since it was working fine with the previous version I tried to revert, uninstalling the new version, but It refused to go away, at that time I started to get the «system error code 126» everytime I tried to anything related to the myODBC driver in the windows Data Source ODBC interface, which continued to report having version 3.51.10 installed.
To fix this problem I had to stop all services, remove the myodbc dlls by hand, and then opted to install version 3.51.08, to minimise server down time, since I was not willing to go through the same ordeal once again. Later I will try to upgrade again when time permits it, hehe.
Once I installed to myodbc driver again and restarted the computer all went back to normality. I guess then that the error was caused by inconsistency between files of different versions. I hope this helps to find the real cause though.
Till next time, (hope not)
Ivo Valente
[26 Nov 2005 18:05] Steve Morris
Just for interest tried to install MyODBC 5 on a Windows 2000 Advanced Server box, got the error, I already had an earlier version of 3.51 installed, uninstalled it - still got the error. Tried lastest release of 3.51 and it installed fine, and will connect to MySQL 5 which was the reson for upgrading. Unfortunately machine already has MS SQL & Oracle installed/running so maybe not a typical scenario!

However problem with MyODBC 5 did not occur with MyODBC 3.51.12 so presumably not a fundamental machine configuration problem.
[30 Jan 2006 21:53] Remi Arntzen
I tried to install the ODBC Bridge version 5.0 and I got this error.
I'm running Windows XP MCE Version 2002 SP 2

And in regards to  Chris Jeske's post I already have ctl3d32.dll in C:\WINDOWS\system32\

Heino Backhaus's post said to copy the ntctl3d.dll file but I have no such file on my computer.
[3 Jun 2006 2:22] Hector Santos
I'm relatively new to MYSQL and we began to add MYSQL to two our our NT 4.0 servers.  We do expect to upgrade them within the next 3-4 months.  However, I got excited that everything installed and worked on one NT 4.0 machine, including MYODBC 3.51, but on the second one,  everything installed, but I am getting this ADD DSN error 998/translator library error when adding a DSN via ODBC32.

So obviously, it works but there is a difference in the OS files required to make it work.   I am currently comparing the two machines.
[16 Mar 2012 17:58] Ricardo Simental
I am running Windows NT4 in VMWare and tried to install the ODBC connector for MySQL, but got the same error.

"Error 1918. Error installing ODBC driver MySQL ODBC 3.51 Driver, ODBC error 13: Could not load the setup or translator library. Verify that the file MySQL ODBC 3.51 Driver exists and that you can access it."

Is there a way to avoid this and properly install the connector?
[4 Aug 2015 19:12] Shakeel Mir
i am using Window server 2008 R2 and i am trying to installed the mysql-connector-odbc-3.51.30-winx64 and getting error 1918 error installling ODBC driver mySQL ODBC 3.51 driver ODBC could not be loaded due to system error code 126. the specified module could not be found ...\myodbc3s.dll..