Bug #15858 Stored proc - killing process via MySQL administrator
Submitted: 19 Dec 2005 12:12 Modified: 19 Dec 2005 12:23
Reporter: Peter Larb Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.16 OS:Microsoft Windows (Win2000)
Assigned to: Miguel Solorzano CPU Architecture:Any

[19 Dec 2005 12:12] Peter Larb
Description:
Good evening

Please advise how to send you a file with a screenshot

Thankyou

Peter

How this problem began and occured:
1. Ran an update stored procedure which took 12mins and didn't complete successfully but only had 60,000 rows to modify.
2. Killed the process using MySQL Administrator.
1. Edited the stored procedure to change the column name from "index" to "`index`" via MySQL Administrator, after trying to save changes to the stored procedure, mysql-nt.exe crashes with an error. 
2. Rebooted computer. Started up MySQL Administrator and clicked stored procedure, mysql-nt.exe crashes again with the same error.
3. Rebooted computer. Started up MySQL command line client and these commands in order:
        use alphamodel;
        select count(*) from alphamodel_quintiles_alpha; (to check that I can see the data)
        show procedure status;
mysql-nt.exe crashes with an error.
 
 
It seems everytime I try to view my stored procedures mysql-nt.exe would crash, restarting the server didn't work, computer had to be rebooted.
 
A possible problem would be that a column in the table that the stored procedure uses has a column called index. The original person who wrote the query in MS Access (this is a MS Access conversion to MySQL) didn't use `` quotes to quote the column name and when I tried to correct that error and save the stored procedure, those errors started to occur.

How to repeat:
Kill a stored procedure using MySQL admin that seems to be "locked" and include columns that are called "index".
[19 Dec 2005 12:23] Miguel Solorzano
Thank you for the bug report.

Duplicate of bug http://bugs.mysql.com/bug.php?id=15367.