Bug #15818 error: No curses/termcap library found
Submitted: 17 Dec 2005 3:17 Modified: 13 May 2006 2:05
Reporter: abcwsd Jie Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version: OS:Linux (ubuntu breey)
Assigned to: CPU Architecture:Any

[17 Dec 2005 3:17] abcwsd Jie
Description:

checking for termcap functions library... configure: error: No curses/termcap library found

How to repeat:
./configure --prefix=/usr/local/mysql
[17 Dec 2005 13:51] Valeriy Kravchuk
Thank you for a problem report. I suppose, you mean Ubuntu 5.10 "The Breezy Badger" as your OS? Please, inform about the exact version fo MySQL you are trying to build there.

I have Ubuntu 5.04. Is it OK to check on it or 5.10 is much different?
[18 Jan 2006 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[25 Apr 2006 2:10] Bradley Snobar
This bug still occurs.  If there is a workaround, please post it.
[25 Apr 2006 2:12] Bradley Snobar
FYI: Here is a link I found that may have the solution.

http://www.ubuntuforums.org/showthread.php?t=93725
[13 May 2006 1:20] Miguel Solorzano
Thank you for the bug report.

checking for tgetent in -ltinfo... no
checking for termcap functions library... configure: error: No curses/termcap library found
miguel@hegel:~/dbs/mysql-4.1$

I will see if I find a workaround.
[13 May 2006 2:05] Miguel Solorzano
Thank you for the bug report. The issue is that the ncurses stuff isn't
instaled for to find which name Ubuntu uses for that library I did:

apt-cache search ncurses

and I found:

libncurses5-dev - Developer's libraries and docs for ncurses

and installed it with:

apt-get install libncurses5-dev

On my side also I needed to do the same with OpenSSL stuff:
apt-cache search openssl
apt-get install libssl-dev
[9 Feb 2007 19:58] Andrzej Krecijasz
I tried to install on Debian SARGE and I get the same problem.
apt-get install libncurses5-dev  solved problem.

Thanks
[5 Jul 2007 12:57] mohamed guechbar
I had the same problem on Debian etch and : apt-get install libncurses5-dev    solved it
[9 Sep 2007 17:35] Atli Jónsson
Had this error on Fedora 7.
Fixed it by doing: yum install ncurses-devel
[10 Feb 2008 21:38] Catalina Vazquez
I had the same problem on CentOS 5.1: 
checking for termcap functions library... configure: error: No curses/termcap library
found

and i also fixed it by doing: yum -y install ncurses-devel
[6 Apr 2008 8:52] hou qinglong
I also had the same problem on CentOS5.1,also fixed it by doing:yum -install ncurses-devel
[4 Jun 2008 15:58] Timo Gutstein
I also had the same problem on Ubuntu Gusty Gibbon and and : apt-get install libncurses5-dev    solved it

Thanks
[10 Jul 2008 19:18] Kevin Hebert
I had the same bug on CentOS 5.2, fixed with yum -y install ncurses-devel
[4 Dec 2008 20:26] Pedro Sousa
Had same problem at SuSE 10.0.

Installed ncurses-devel-5.4-71 and still get the error.

techserver512-1:~/instalados/mysql-4.1.22 # rpm -qa |grep ncurses
ncurses-5.4-71
yast2-ncurses-2.12.6-2
ncurses-32bit-5.4-71
ncurses-devel-5.4-71
techserver512-1:~/instalados/mysql-4.1.22 #

techserver512-1:~/instalados/mysql-4.1.22 # rpm -qa |grep term
libiterm-0.5.20040304-28
terminfo-5.4-71
libiterm-devel-0.5.20040304-28
techserver512-1:~/instalados/mysql-4.1.22 #

(... on mysql 5.1.30)
checking for tgetent in -ltinfo... no
checking for termcap functions library... configure: error: No curses/termcap library found
(...)

(... on mysql 4.1.22)
checking for tgetent in -ltinfo... no
checking for termcap functions library... configure: error: No curses/termcap library found
(...)

Seems missing some path. Any idea?
[19 Apr 2009 21:07] Diane Lord
Had the same problem with 5.1.33 source on Suse 11
installing ncurses-devel 5.6-89.10 did the trick
[9 Jul 2009 0:39] Alessandro Micaglio
[13 May 2006 4:05] 

On a Kubuntu OS 2.6.28-11, according to Miguel Solorzano (see previous post) to fix the bug:

apt-cache search ncurses

and I found:

libncurses5-dev - Developer's libraries and docs for ncurses

and installed it with:

apt-get install libncurses5-dev
[25 Oct 2009 17:37] Eueal Tadele
I came across the same bug on CentOS 5.3 while compiling MySQL 5.0.86 and error was fixed by installing ncurses-devel
[24 Nov 2009 12:31] tran luong
I had the same problem on CenOS 5.4: 
    
 checking for termcap functions library... configure: error:                   No  curses/termcap library found

and I also fix it by doing : yum install ncurses-devel
[16 Feb 2010 9:43] Sergei Ryazansky
I had the same problem on cygwin 2.677 and installing libncurses-devel and ncurses packages solved it
[16 Feb 2010 9:50] Sergei Ryazansky
I had the same problem on cygwin 2.677 and installing libncurses-devel and ncurses packages solved it
[23 Mar 2010 12:06] Ilya Smolkov
Hi All! The problem may be solved with installation ncurses-devel package. For OpenSUSE  you should search the ncurses-devel in YaST and install it. For me it's works.
[16 Aug 2010 16:51] Allyson Oliveira
Dear friends,

I Have a OpenSuse 11.3 system and i solve this problem at this way:

1-) zypper (apt-get from Suse) search ncurses
the answer:

S | Name                | Summary                                               | Type
--+---------------------+------------------------------------------------------
i | libncurses5         | The New curses Libraries | package
i | libncurses6         | The New curses Libraries | package
i | ncurses-devel       | Include Files and Libraries mandatory for Development | package
i | ncurses-utils       | Tools using the new curses libraries | package
i | yast2-ncurses       | YaST2 - Character Based User Interface | package
i | yast2-ncurses-devel | YaST2 - Character Based User Interface | package
i | yast2-ncurses-pkg   | YaST2 - Character Based Package Manager Frontend | package

In my case, i don't have all of this libs, and i give zypper install nameoflib and after i give ./configure --prefix=/usr/local/mysql and the problem is solved!

Thanks,

Allyson Oliveira.
[25 Apr 2011 13:38] ds dsd
slackware - I install ncurses-5.7 tar.gz and problem has fix.
[7 Nov 2012 17:22] J R
I had the same problem on Ubuntu 12.04
apt-get install libncurses5-dev solved the problem