Bug #1567 A bug fixed in 4.0.14 and related to variable values is still not fixed
Submitted: 16 Oct 2003 4:18 Modified: 22 Oct 2003 14:11
Reporter: Lokesh Babu Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.0.15 OS:Microsoft Windows (Windows and NetWare)
Assigned to: CPU Architecture:Any

[16 Oct 2003 4:18] Lokesh Babu
Description:
In the diff list of 4.0.14 release (http://www.mysql.com/doc/en/News-4.0.14.html) it is mentioned that, a defect related to maximum value of variables is fixed and mentioned as follows:
"Fixed a bug that limited the maximum value for mysqld variables to
4294967295 when they are specified on the command line"
But, I tried this with 4.0.15 build on NetWare and Windows and the defect is still there on both the platforms. I tried to set the MAX_BINLOG_SIZE value to 4294967295. But, when I queried using, show variables like "max_binlog%"; it shows the value as  1073741824.

I tried to trace the code, but could not. I tried even with debug build also. But, could not find where to start.

How to repeat:
1. Either on Windows or NetWare, start MySQL.
2. From mysql monitor, set MAX_BINLOG_SIZE as follows:
 set global MAX_BINLOG_SIZE = 4294967295;
3. Query the MAX_BINLOG_SIZE value as follows:
 show variables like "max_binlog%";
4. Result on my machine:
 +-----------------------+------------+
| Variable_name         | Value      |
+-----------------------+------------+
| max_binlog_cache_size | 4294963200 |
| max_binlog_size       | 1073741824 |
+-----------------------+------------+
[22 Oct 2003 14:11] Dean Ellis
max_binlog_size cannot be set to a value greater than one gigabyte.  This is mentioned in the documentation, which you can view online at:

http://www.mysql.com/doc/en/SHOW_VARIABLES.html

Thank you