Bug #15512 crash during online add of API/SQL node
Submitted: 6 Dec 2005 8:14 Modified: 8 Dec 2005 23:57
Reporter: Kolbe Kegel Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version:5.0.16 OS:
Assigned to: Stewart Smith

[6 Dec 2005 8:14] Kolbe Kegel
Description:
The cluster undergoes a forced shutdown when the management daemon is restarted with a changed config.ini file.

How to repeat:
1. Shutdown ndb_mgmd
2. Quit ndb_mgm
3. Add a [MYSQLD] section to config.ini
4. Start ndb_mgmd
5. Start ndb_mgm

pbnj:~/Devel/mysql/cluster kolbe$ ndb_mgm
-- NDB Cluster -- Management Client --
ndb_mgm> show
Connected to Management Server at: localhost:1186
Node 2: Forced node shutdown completed. Initiated by signal 10. Caused by error 6000: 'Error OS signal received(Internal error, programming error or missing error message, please report a bug). Temporary error, restart node'.
Node 3: Forced node shutdown completed. Initiated by signal 10. Caused by error 6000: 'Error OS signal received(Internal error, programming error or missing error message, please report a bug). Temporary error, restart node'.
Cluster Configuration
---------------------
[ndbd(NDB)]     2 node(s)
id=2    @127.0.0.1  (Version: 5.0.16, Nodegroup: 0, Master)
id=3    @127.0.0.1  (Version: 5.0.16, Nodegroup: 0)

[ndb_mgmd(MGM)] 1 node(s)
id=1    @127.0.0.1  (Version: 5.0.16)

[mysqld(API)]   3 node(s)
id=4    @127.0.0.1  (Version: 5.0.16)
id=5    @127.0.0.1  (Version: 5.0.16)
id=6 (not connected, accepting connect from any host)

ndb_mgm> show
Cluster Configuration
---------------------
[ndbd(NDB)]     2 node(s)
id=2 (not connected, accepting connect from localhost)
id=3 (not connected, accepting connect from localhost)

[ndb_mgmd(MGM)] 1 node(s)
id=1    @localhost  (Version: 5.0.16)

[mysqld(API)]   3 node(s)
id=4 (not connected, accepting connect from any host)
id=5 (not connected, accepting connect from any host)
id=6 (not connected, accepting connect from any host)

Suggested fix:
The cluster should not shutdown when a [MYSQLD] section is added to the config file and the node is restarted.
[6 Dec 2005 8:44] Stewart Smith
A workaround is to not run 'show' when performing the upgrade as we die on the signal that asks the API nodes for the connected address of the API (that we don't have a transporter to).

Patch coming
[6 Dec 2005 10:25] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/33060
[6 Dec 2005 12:15] Stewart Smith
Pushed to 5.0.17
[8 Dec 2005 23:57] Paul Dubois
Noted in 5.0.17 changelog.
[18 Jan 2006 8:24] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/33354