Bug #15490 administrator gets lost in my.cnf with multiple mysql* sections
Submitted: 5 Dec 2005 14:13 Modified: 6 Jul 2006 8:57
Reporter: Jesper Hørup Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.1.5 OS:Microsoft Windows (Windows)
Assigned to: Mike Lischke CPU Architecture:Any

[5 Dec 2005 14:13] Jesper Hørup
Description:
Similar to #9908

Having a two-servicses setup on one PC with one .cnf, having these two sections:
[mysql-11]
datadir         = C:/MySQL/data_11/
port            = 3306
server-id       = 1
bind-address    = 10.10.150.11

[mysql-20]
datadir         = C:/MySQL/data_20/
port            = 3306
server-id       = 2
bind-address    = 10.10.150.20

Installed and started them like this:
  c:\mysql\bin\mysqld-opt.exe --install mysql-11
  c:\mysql\bin\mysqld-opt.exe --install mysql-20
  net start mysql-11
  net start mysql-20

Start adminstrator for 'mysql-20'-service and  "Service Control" tab shows data fro 'mysql-11' service.

How to repeat:
Make my.cnf as shown in description
Install servicses and start servicses.

start Administrator whith connection nr:2 and "service control" shows data for service nr:1
[7 Dec 2005 20:44] Vasily Kishkin
As far as I can understand you try to start two services which use one TCP/IP port. Could you please change in section mysql-20 TCP/IP port and try again ?
[7 Dec 2005 21:11] Jesper Hørup
Yes, I _do_ start two servicses on One PC on the same port(3306), but I have bound each service to a spefic IP. (In the "advanced" tab of the TCP/IP protocol I have added two IP's to the same NIC)
I can use command-line mysql.exe or MySQL ControlCenter to connect to the different servicses. I is only Administrator which gets confused over the two servicses.
I'll try to change the port and let you know the result.
[11 Dec 2005 16:43] Vasily Kishkin
I was able to reproduce the bug. Probably Administrator take any information about service from first service of secvice list.
[3 Jan 2006 15:58] Mike Lischke
This behavior is kind of intended. Actually, MA cannot handle multiple installed instances well. It was never made for such a case as this will be handled by the new tools, which are currently under development. So it makes no sense to build that feature also into MA.

Mike
[3 Jan 2006 19:15] Jesper Hørup
Mike,
can you reveal names and expected release dates for the new tools?
[6 Jul 2006 8:57] Jesper Hørup
At 3 jan 2006, you wrote about development of new tools for handling multiple instances of Mysql server.

6 months has passed, but no new tools.

Will you re-open this case, or can you give an estimate when We see the new tools.