Bug #15320 Failure To Load driver in Visual Basic
Submitted: 29 Nov 2005 17:22 Modified: 28 May 2013 12:53
Reporter: Howard Bannerman Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.12 OS:Microsoft Windows (Windows xp service pack 2)
Assigned to: CPU Architecture:Any

[29 Nov 2005 17:22] Howard Bannerman
Description:
When I use data link or even without data link with just regular ado obdc connection I get a Castrophic error or it won't even connect to the mysql database.Ive read online and it sais to apply the patch but it still doesn't work?

How to repeat:
Create a dsn connection.Start a new project and start a datalink connection and try to connect you get the error when you try to pick an initial catalog.If you don't pick an initial catalog the project will not work!Also try just an ordinary ado connection it still doesn't work!
[29 Nov 2005 17:23] Howard Bannerman
Ive been tolled to use mdac 2.8 and it still doesn't work?
[29 Nov 2005 17:24] Jorge del Conde
Hi!

Thanks for your bug report.  I was able to reproduce this by not selecting an initial catalog as stated in your post.
[29 Nov 2005 17:29] Howard Bannerman
Any suggestions how to resolve this? I know its not my dsn connector because Ive tested my project with access with a dsn connection and it worked fine.
[29 Nov 2005 17:32] Howard Bannerman
Ive tried using the obdc 3.51 patch 3 and it still won't work!Ive noticed users saying to keep the intial catlog blank and it will work but it doesn't only part way yes some querys work but not to the full extent therefore the connection is not flawless and the project will not work correctly.
[29 Nov 2005 21:59] Howard Bannerman
What previous edition of connector works for this project?
[13 Aug 2007 12:37] Miguel Solorzano
Please try the latest release 3.51.19. Thanks in advance.
[13 Sep 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 May 2013 12:53] Bogdan Degtyariov
Thank you for your bug report. This issue has already been fixed in the latest released version of that product, which you can download at

  http://www.mysql.com/downloads/