Bug #1532 convert function is not working properly
Submitted: 11 Oct 2003 5:28 Modified: 11 Oct 2003 8:02
Reporter: Manish Runwal Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: User-defined functions ( UDF ) Severity:S3 (Non-critical)
Version:3.23.57 OS:Microsoft Windows (window98)
Assigned to: CPU Architecture:Any

[11 Oct 2003 5:28] Manish Runwal
Description:
I created one "table1" table contain one "col1" column as varchar(20)
but having data as int.
when I m use following query its not working.

select convert(Column_name,unsigned) from table_Name;

err is as follows:

ERROR 1064: You have an error in your SQL syntax near '(col1,unsigned) from tabl
e1' at line 1

From
Manish Runwal
m_runwal@sancharnet.in

How to repeat:
even when I use cast function its not working.
I think there is not syntax error in tht.

Suggested fix:
Can't say !
[11 Oct 2003 8:02] MySQL Verification Team
Please don't submit the same report twice. Duplicate of bug# 1531
[21 Aug 2007 12:34] satheesh kumar
hi I need to convert the int data type to varchar how to do that in mysql lte me know pls ...