Bug #15209 MySQL installation problem on Windows ME
Submitted: 24 Nov 2005 0:24 Modified: 21 Dec 2005 14:59
Reporter: peter phengmaly Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.16 OS:Microsoft Windows (Windows ME)
Assigned to: Ramil Kalimullin CPU Architecture:Any

[24 Nov 2005 0:24] peter phengmaly
Description:
I've made a pure 5.0.16 install on Windows ME, with default settings. After installation mysqld could not be started. I typed

mysqld --defaults-file="c:\WINDOWS\my.ini"

Then it says :

051124  1:14:00 [ERROR] Can't find messagefile 'C:\Program Files\MySQL\MySQL Server 5.0\share\english\errmsg.sys'
051124  1:14:00 [ERROR] Aborting

May this be because this OS is not supported anymore ?

How to repeat:
Install 5.0.16 on a Win ME without any formerly installed MySQL.
[24 Nov 2005 0:43] Miguel Solorzano
Please verifiy where you have your my.ini file:

c:\windows\my.ini

or

C:\Program Files\MySQL\MySQLServer 5.0\my.ini

or both.

and use only one and verify the correct path for basedir and datadir.

Thanks in advance.
[24 Nov 2005 19:48] Federico Santandrea
I'm on Windows 98SE and the same thing happens to me. Nothing to do with the paths although, I've tried using the language parameter

mysqld --language [filepathandname]

I tried to copy the errmsg.sys file even in the root directory and then did

mysqld --language c:\

It said that "C:\errmsg.sys" did not exist, but in fact it DOES exist.

This problem occurs even with the file in its original path, I've just moved it to root directory to make sure it wasn't an invalid path problem... I don't have a clue.
[24 Nov 2005 22:35] peter phengmaly
I only have c:\windows\my.ini, and it contains correct paths.
There is no my.ini in C:\Program Files\MySQL\MySQLServer 5.0
[24 Nov 2005 22:42] Miguel Solorzano
Could you please see in your my.ini file if the keys basedir and datardir
are pointing for correct paths?

i.e:

basedir="C:/Program Files/MySQL/MySQLServer 5.0"
datadir="C:/Program Files/MySQL/MySQLServer 5.0/data"

notice if you open a DOS prompt in the install bin directory
the server should be able to start:

mysqld --standalone --console
[25 Nov 2005 13:01] Federico Santandrea
I have already said that the paths are correct, and the program searches for the correct file in the correct directory, and the file exists, but it gives me this error. The paths are absolutely ok...
[25 Nov 2005 14:01] peter phengmaly
Hello,

The path entries point to the correct dirs.
I tried both the slash-separated and the double-backslash-separated format.

Thanks,
Peter
[26 Nov 2005 10:52] Jorge del Conde
I was able to reproduce this bug using Win98SE
[28 Nov 2005 17:41] Marcus Fernandez
I have the some problem on OS Win98SE.
On I got start mysqld I give a message calling with not found the file errmsg.sys, but the file already exist on local that error message show.
I've tryed to reinstall and the error persists.
**sorry my stupid english**
[11 Dec 2005 23:28] [ name withheld ]
I get the same error, I'm going to try to install MySQL 4.1
[12 Dec 2005 8:18] Dagmar Schmalhorst
However, I think the problem is due to a path fixedly implemented into the MySQL-runtime anywhere. I changed the path in the basedir- and datadir-statements in the my.ini to ... MySQL_server_5.0 ...but still the error message comes up saying "Can't find message file C;\programme\mysql\mysql server 5.0\share\english\errmsg.sys", i.e. without underscores!! When changing directories using the MS-DOS-prompting possibility you cannot say either
c:>cd ... mysql server 5.0 ...
Though the path is corrctly displayed in the prompting-statement:
C:\programme\mysql\mysql server 5.0\bin ...
the cd-command comes up with a mistake after the "c:>cd ... mysql server 5.0 ..."-command. It cannot cope with the blanks in the path-name.
From that it may be concluded that Windows ME (and its predecessors Windows 98 and 95) cannot cope with the path-directions. And these seem to be built in in the Mysql-kernel.
[13 Dec 2005 8:22] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/33219
[13 Dec 2005 14:37] Ramil Kalimullin
fixed in 5.0.17
[21 Dec 2005 14:59] Jon Stephens
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at 
http://www.mysql.com/downloads/

Additional info:

Documented bugfix in 5.0.17 changelog. Closed.
[26 Aug 2006 19:05] suresh NULL !
This problem still exists on Windows 98. I just downloaded 5.0.24-community-nt for win32 on ia32 today.
[10 Nov 2007 15:57] Dmitry Koterov
I have also reproduced this bug in Windows 98 SE.
The message is:

Z:\usr\local\mysql5\bin>mysqld.exe
071110 18:48:57 [ERROR] Can't find messagefile 'C:\WEBSER~1\USR\LOCAL\MYSQL5\share\english\errmsg.sys'
071110 18:48:57 [ERROR] Aborting

This path is correct, file exists.
I used filemon th watch what files are used during the mysql startup and noticed that C:\WEBSER~1\USR\LOCAL\MYSQL5\share\english directory is checked (with status Success), but the file errmsg.sys is never requested (no filemon row for that file exists, so mysqld.exe never opens nor checks this file).

The version is:

Z:\usr\local\mysql5\bin>mysqld.exe --version
C:\WEBSER~1\USR\LOCAL\MYSQL5\BIN\MYSQLD.EXE  Ver 5.0.45-community-nt for Win32 on ia32 (MySQL Community Edition (GPL))

This bug is NOT reproducible in Windows XP.
[10 Nov 2007 17:49] Kent Boortz
The reason you get the same error in 5.0.41 and 5.0.45
is unrelated to the original problem. There was a packaging
flaw in 5.0.41 and 5.0.45 where the "mysqld.exe" was an
exact copy of "mysqld-nt.exe", i.e. the version that
doesn't work for Windows 98/ME. If you run
"mysqld.exe --version" you will see that it identifies
itself as "Ver 5.0.45-community-nt", the non 98/ME
version. Also "mysqld.exe" and "mysqld-nt.exe" has
the same MD5 checksum.

This should be corrected in the next 5.0 release.