Bug #15175 Fails to run the migration toolkin on Windows System
Submitted: 23 Nov 2005 6:23 Modified: 5 Dec 2005 21:08
Reporter: Ashish Annachhatre Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S3 (Non-critical)
Version:1.0.20 OS:Microsoft Windows (Windows XP (sp2))
Assigned to: CPU Architecture:Any

[23 Nov 2005 6:23] Ashish Annachhatre
Description:
I installed Migration toolkit on Windows XP (sp2) machine. But while installation I choose to change the default installation path. Application installed perfectly alright.

Then I tried to run it from start->Mysql->... it refused to run by giving some beared java errors.

I crosschecked that I have all latest JRe and Java installed properly on my machine. I tried uninstalling and re-installing JRE and Java on my machine... restarted computer... but still Migration Toolkit reused to run.

When I checked  the "start in" property of this migration toolkit shortcut, I found that it is pointing to wrong (default) installation directory. When I changed this to correct directory everything worked properly.

-Ashish

How to repeat:
Install Migration Toolkit on Windows XP (sp2) machine and while installation choose different Target Path (not the default).
[23 Nov 2005 6:27] Jorge del Conde
Thanks for your bug report.  I installed MT in D:\my\migration toolkit and the bug you described happened.
[5 Dec 2005 21:08] Michael G. Zinner
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html