Bug #15097 missing LF at end of version string of mysql.exe
Submitted: 21 Nov 2005 13:16 Modified: 9 Dec 2005 19:47
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.0.16 OS:Microsoft Windows (Win XP)
Assigned to: Kristian Nielsen CPU Architecture:Any

[21 Nov 2005 13:16] Carsten Segieth
Description:
when calling 'mysql --version' the 'Copyright ...' sting is shown on the same line and not - as for all other command line tools, if present - in the next line:

c:\MySQL\mysql-pro-gpl-5.0.15-win32\bin\mysql.exe  Ver 14.12 Distrib 5.0.15, for Win32 (ia32)Copyright (C) 2002 MySQL AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
...

c:\MySQL\mysql-pro-gpl-5.0.15-win32\bin\mysqlmanager.exe Ver 0.2-alpha for Win32 on ia32
Copyright (C) 2003, 2004 MySQL AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
...

How to repeat:
mysql --help | head -10
and check against
mysqlmanager --help | head -10

Suggested fix:
add missing LF to end of version string
[21 Nov 2005 13:17] Carsten Segieth
It looks that this appears only on Windows, I could not reproduce it with current 5.0.17-bk on Linux (Suse 9.3).
[21 Nov 2005 14:23] Carsten Segieth
sorry, it should have been 'mysql --help' in the description (as listed in 'how to repeat). '--version' doesn't show a Copyright string.
[5 Dec 2005 11:18] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/33019
[9 Dec 2005 19:47] Paul DuBois
Noted in 5.0.17 changelog.