Bug #15082 TADOConnection and ODBC 3.51.12 raise E_FAIL
Submitted: 20 Nov 2005 14:28 Modified: 28 May 2013 12:55
Reporter: Marcus Rieche Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51.12 OS:Microsoft Windows (Windows XP Pro)
Assigned to: CPU Architecture:Any

[20 Nov 2005 14:28] Marcus Rieche
Description:
Under Delphi 2005 with all Updates and an Windows XP Pro System also with all Updates, I set up an Win32 Form and places an TADOConnection, TADOTable, TDataset and a TDBGrid.
I have the MySQL Server 4.1.14 installed. There is a table called Ruecknahme.
When i try to get some special rows of that table i get an E_FAIL and no data were returned.
I can reproduce it when i try to call these rows. I don't know what could be the difference between that few rows and the others.

I hadn't these problems with the BDE. Maybe its only a problem somewhere around the ADO libraries. But i need to start to ask somewhere.

thanks

How to repeat:
Just try to watch the few rows again.

Suggested fix:
no idea
[20 Nov 2005 14:45] Valeriy Kravchuk
Thank you for a problem report. Please, send the SHOW CREATE TABLE results for the problematic table and describe the data it contains. Or just upload the dump. 

Can you switch on ODBC trace for the data source and try to figure out what ODBC call is problematic (giving error)?
[23 Nov 2005 10:15] Vasily Kishkin
Thanks for bug report. I was able to reproduce the bug on Delphi 7.0. A screen copy with error message is attached.

To Harvey - do I need to create test case on C ?
[23 Nov 2005 10:16] Vasily Kishkin
screen copy

Attachment: sc15082.GIF (image/gif, text), 35.85 KiB.

[24 Aug 2007 10:44] Susanne Ebrecht
Hi Marcus,

Please, can you try this again with the newest ODBC version (3.51.19) and let us know, if the error is still occur.

FYI: I found an error in your table: decimal(m,n)

m: is the number of all numbers you want to store including the "Nachkommastellen".
For example: for a maximum of 9999.99 the m should be 6 and for a maximum of 999.99 the m should be 5.
You tried to store 1000.00 so the m must be bigger than 5.

n: is the number of "Nachkommastellen".

In a decimal(5,2) you can only store number until 999.99.
[24 Sep 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 May 2013 12:55] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.