Bug #1497 ?
Submitted: 7 Oct 2003 6:53 Modified: 26 Nov 2005 12:58
Reporter: [ name withheld ] Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: MyISAM storage engine Severity:S4 (Feature request)
Version:latest OS:Linux (linux/freebsd)
Assigned to: CPU Architecture:Any
Triage: D5 (Feature request)

[7 Oct 2003 6:53] [ name withheld ]
Description:
It could be nice to have mysql create new tables under MERGE when the oldest reaches a predetermined MAXSIZE. As it is now, I have to periodically create new tables and manually add them to the .MRG file as they would become become too big for the filesys.

How to repeat:
It's not a bug

Suggested fix:
No fix. This is merely a suggestion.
[26 Nov 2005 12:58] Valeriy Kravchuk
Thank you for a feature request. 

Sorry, but any reorganization of tables and table structure is a sole task of the database administrator, not of the server. You can create a set of SQL statements that will drop the MERGE table and create it based on a new set of tables periodically. Nobody will do it for you, really.