Bug #14957 Cannot find myodbc3d.dll in the distribution
Submitted: 15 Nov 2005 20:01 Modified: 26 Nov 2005 3:16
Reporter: Samuel D'Costa Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version: OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[15 Nov 2005 20:01] Samuel D'Costa
Description:
Cannot find myodbc3d.dll in the install or distribution.
Where can we find this file?

How to repeat:
* Download installer (msi or exe).
* install
* Look under system32 to find myodbc3d.dll

OR

* Download zip
* explore zip file for myodbc3d.dll

Cannot find the file in either circumstance.
[15 Nov 2005 21:13] Vasily Kishkin
You can download sources of myodbc and build them from URL:
http://dev.mysql.com/get/Downloads/MyODBC3/mysql-connector-odbc-3.51.12-win-src.zip/from/p...
[20 Nov 2005 2:41] Samuel D'Costa
Since I do not have access to the build environment, have been unable to build from source. Tried to find nmake (downloaded MDAC) however could not figure out how to proceed. Giving up.
Thanks for your help.
[22 Nov 2005 17:00] Jorge del Conde
I was unable to reproduce this under XP/XP64
[26 Nov 2005 3:12] Samuel D'Costa
Hi,

Does that mean you were able to find the myodbc3d.dll in the distribution?
Or were you able to build from source and then find the myodbc3d.dll in the distribution?
In any case, I am working with Apache Derby with much success.
Thanks for your time guys, please feel free to mark this one closed.
[26 Nov 2005 3:16] Samuel D'Costa
Minor correction: MS Access instead of Apache Derby

Was able to get by with using MS Access (much as I hate to admit that) since it was not possible to see the errors (since I could not find the dll) and MS Access worked without any errors.

In any case, this was for a development project, so thanks again for your time.