Bug #14937 Crashes upon launching under WinXPPro
Submitted: 15 Nov 2005 6:20 Modified: 21 Nov 2005 18:23
Reporter: Timothy Trimble Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S1 (Critical)
Version:1.0.20 rc OS:Microsoft Windows (Windows XP Pro)
Assigned to: CPU Architecture:Any

[15 Nov 2005 6:20] Timothy Trimble
Description:
Upon launching the Migration toolkit, I get the following error: "file .\source\myx_grt_struct.c: line369: assertion 'gstruct != NULL' failed"
When I click OK I then get the following:
The GRT environment could not be initialized.  Please check your java installation then try to restart the tool.  
Error details: Migration.initMigration: The function did not return an object. Error Nr. 100003

Shell output:
MySQL Generic runtime environment 2.0.11 beta

Error while loading struct definitions (10001).
Initializing native loader...
Initializing java loader...
Error initializing java module loader (10001). Please check the .\java and .\java\lib directories
Initializing Lua loader...
Registered 3 builtin modules.
Cannot find module directory ./lua.
Error while loading Lua modules (10001).

How to repeat:
Launch the Migration Toolkit
[15 Nov 2005 10:01] Valeriy Kravchuk
Thank you for a problem report. I've just launched the same version of Migration Toolkit on XP Pro without any problems. So, I have a couple of questions to you:

1. Is it plain XP or any SP installed?
2. Do you have any Java Runtime Environment (JRE) installed? What versions, if any?
[15 Nov 2005 16:06] Timothy Trimble
I'm running SP2 and the latest critical updates for Windows.  My java version is j2sdk1.4.2.  Let me know if you need any further info.
[18 Nov 2005 17:43] Valeriy Kravchuk
Thank you for the additional information. I'll try with jre 1.4.2 on XP SP2, but I found that the latest Java on my box where it works OK is jre 1.5.0_02. So, can you, please, try to install Java 5.0 and check once more?
[18 Nov 2005 18:22] Timothy Trimble
I installed java 5.0.  Uninstalled the Migration toolkit.  Reinstalled the Migration toolkit.  Still getting the same errors.

WinXPPro with SP2 & latest critical patches
RIM JDE SDK - 4.0.2
Java 5.0
Open Office 2.0
FireFox 1.0.7
MS Office XP
iTunes w/Quicktime
AntiVir AntiVirus
Microsoft AntiSpyware
MS Visual Studio dot Net 1.0
NetBeans 4.1
Codewarrior for Palm OS 9.0
[19 Nov 2005 16:34] Valeriy Kravchuk
Please, look at the bug report http://bugs.mysql.com/bug.php?id=14041. Your's looks similar to that one. May be, one of the ideas about the reason expressed there will help you too. Inform about any results.
[19 Nov 2005 21:06] Timothy Trimble
Changing the properties for the link fixed the problem.  Seems that if you use a non-standard installation path that the installer doesn't update the launch icon appropriately.
[21 Nov 2005 18:16] Jorge del Conde
Hi!

I can't find a way to reproduce this bug.  Can you please check your JAVA installation and ensure its working correctly ?  MT ran perfectly fine for me.

Thanks
[21 Nov 2005 18:23] Timothy Trimble
To reproduce this bug, during installation, you have to select a drive and/or path that is different than the default.  Then when you launch you will see the error.  The problem is with the icon not being updated with the correct drive/path during installation.