Bug #14936 MyODBC driver does not appear in Admin if FileMaker 7/8 Installed
Submitted: 15 Nov 2005 6:10 Modified: 30 May 2008 19:18
Reporter: Timothy Trimble Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51 OS:Microsoft Windows (Windows XP Pro)
Assigned to: CPU Architecture:Any

[15 Nov 2005 6:10] Timothy Trimble
Description:
I had an installation of FileMaker 7, and FileMaker 8 Advanced installed on my WinXP Pro system.  I attempted multiple times to install the MyODBC driver using both the msi file and the Setup.exe file.  In both cases, the ODBC driver would not show up in the ODBC Administrator.  After seeing the "closed" bug in the database regarding this issue, I assumed that it was still a problem.  So, I uninstalled both versions of FileMaker.  Then I installed MyODBC via the Setup.exe file.  The ODBC driver now appeared.  I then reinstalled FileMaker Pro 8 Advanced, and the ODBC driver is still there.

How to repeat:
Install FileMaker before installing MyODBC.  Then install MyODBC.  Driver will not appear in the ODBC Administrator

Suggested fix:
The only workaround currently is to uninstall FileMaker, install MyODBC, then reinstall FileMaker.
[15 Nov 2005 18:26] Timothy Trimble
BTW: This is pretty important to me since I'm currently writing a book about FileMaker Pro, and I'm including a section on how to connect to MySQL.  I'll be addressing this with the FileMaker folks as well.
[17 Nov 2005 7:57] Vasily Kishkin
Could you please say me where I can read (URL) about FileMaker ?
[17 Nov 2005 17:49] Timothy Trimble
FileMaker can be found at http://www.filemaker.com

They do have a 30 trial version that can be freely downloaded for testing with.
[24 Nov 2005 11:08] Vasily Kishkin
I installed FileMaker Pro 8.0v1 and after I installed myodbc 3.51.12. There was not any problem. I was able to see it in ODBC Data Sources. What is ODBC Administrator ?
[24 Nov 2005 17:59] Timothy Trimble
ODBC Administrator = ODBC Data Sources.  If it works with FM 8, then maybe it was a problem with 7 since I had both installed at the time.  This was under Win XPPro with SP2 and the latest critical patches.
[1 Dec 2005 18:54] Vasily Kishkin
I was not avaible to reproduce the bug on FileMaker 7. Sorry
[27 Jul 2006 21:33] Cory Bennett
I just encountered this same problem.  The machine had Filemaker Pro 7 and Filemaker Pro 8 installed.  Removing Filemaker Pro 7 fixed the problem.
[18 Oct 2006 10:09] Menno
Just experienced the same problem on Windows XP, SP2. The MyODBC driver did not show up as one of the installed drivers. After uninstalling Filemaker Pro 7 it appeared.
[7 Mar 2008 6:15] Christopher McAvaney
This is exactly the error I was hitting.
It even hid an Oracle ODBC driver that I had installed.
I wonder what on earth FileMaker is doing on installation.

FileMaker version for me was 7.0.3
MySQL ODBC 3.51
[30 May 2008 19:18] Bogdan Degtyariov
Duplicate of Bug#32803