Bug #14783 UPPER/UCASE function not working alongside ENCRYPT/MD5 functions
Submitted: 9 Nov 2005 11:22 Modified: 9 Nov 2005 14:46
Reporter: Cliff Lassnig Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.0.15-standard OS:Linux (Linux x86 using 2.2 Glib build)
Assigned to: Miguel Solorzano

[9 Nov 2005 11:22] Cliff Lassnig
Description:
Function UPPER/UCASE doesn't appear to work when used together with ENCRYPT or MD5 for some reason.

How to repeat:
select UPPER(ENCRYPT('123','MySaLt')) ENCODED;

+---------------+
| ENCODED       |
+---------------+
| MyiOp7ByhM0C2 |
+---------------+

or

select UPPER(MD5('123')) ENCODED;

+----------------------------------+
| ENCODED                          |
+----------------------------------+
| 202cb962ac59075b964b07152d234b70 |
+----------------------------------+

or

select UPPER(MD5(ENCRYPT('123','MySaLt'))) ENCODED_ID;
+----------------------------------+
| ENCODED_ID                       |
+----------------------------------+
| dab2cd07ba03f38f53e134f46382ac4a |
+----------------------------------+
[9 Nov 2005 14:33] Miguel Solorzano
Thank you for the bug report. Duplicate of bug:

http://bugs.mysql.com/bug.php?id=7008
[9 Nov 2005 14:46] Cliff Lassnig
Sorry for wasting your time. We jumped from v3.'something or other' to v5.0.15, that's why I noticed it.