Bug #14687 Cannot access newly created database
Submitted: 6 Nov 2005 20:28 Modified: 6 Nov 2005 22:16
Reporter: Markus Popp Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S2 (Serious)
Version:5.0.15 OS:Microsoft Windows (Windows XP, Linux)
Assigned to: CPU Architecture:Any

[6 Nov 2005 20:28] Markus Popp
Description:
After creating the databases db1 and db2, I was not able to access database db2, although it has been physically created.

How to repeat:
mysql> create database db1;
Query OK, 1 row affected (0.06 sec)

mysql> create database db2;
Query OK, 1 row affected (0.00 sec)

mysql> use db2;
ERROR 1049 (42000): Unknown database 'db2;'
mysql> show databases like 'db%';
+----------------+
| Database (db%) |
+----------------+
| db1            |
| db2            |
+----------------+
2 rows in set (0.00 sec)

mysql>
[6 Nov 2005 22:16] Miguel Solorzano
Duplicate of bug:

http://bugs.mysql.com/bug.php?id=14358