Bug #14463 (Docs Team) PDF misinformation.
Submitted: 29 Oct 2005 12:35 Modified: 29 Oct 2005 21:10
Reporter: Jeff C Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.0.15 OS:Linux (RHEL3)
Assigned to: Miguel Solorzano CPU Architecture:Any
Triage: D4 (Minor)

[29 Oct 2005 12:35] Jeff C
Description:
The PDF linked from mysql.com for triggers is so old it's misleading... You can use select,update...  Perhaps that section needs updating....

<snip>
But remember that functions are subject to severe limitations: you cannot access tables from within a function. So these statements are illegal inside a function:
ALTER 'CACHE INDEX' CALL COMMIT CREATE DELETE
DROP 'FLUSH PRIVILEGES' GRANT INSERT KILL
LOCK OPTIMIZE REPAIR REPLACE REVOKE
ROLLBACK SAVEPOINT 'SELECT FROM table'
'SET system variable' 'SET TRANSACTION'
SHOW 'START TRANSACTION' TRUNCATE UPDATE
Precisely the same limitation applies for triggers.
</snip>

How to repeat:
n/a

Suggested fix:
Update PDF to reflect current abilities of triggers.
[29 Oct 2005 13:28] Miguel Solorzano
Could you please say me which is the lManual's link? I
downloaded the PDF manual from:

http://downloads.mysql.com/docs/refman-5.0-en.a4.pdf

and was unable for to find the quoted text.

Thanks in advance.
[29 Oct 2005 13:56] Jeff C
Sure...

How I found the pdf was:

mysql.com -> clicked on "Mysql 5.0 Triggers" (http://dev.mysql.com/tech-resources/articles/mysql-triggers.html)

Then at the bottom of that doc, you will see the PDF as "click here" ... 
taking you to : http://dev.mysql.com/tech-resources/articles/mysql-triggers.pdf

Thanks,
Jeff
[29 Oct 2005 21:10] Miguel Solorzano
Thank you for the feedback. I am changing as not a bug because it
is a web site issue with an older article. This kind of issue should be
addressed to webmaster@mysql.com.
Please use the link I posted before for to get an updated Manual in
PDF format.
Thanks.