Bug #14432 Unknown SQL Type - 65530 when querying time field
Submitted: 28 Oct 2005 16:56 Modified: 17 Oct 2007 20:21
Reporter: B.J. Nolletti Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.0 OS:Microsoft Windows (Windows XP SP2 & Windows 2k SP4)
Assigned to: CPU Architecture:Any

[28 Oct 2005 16:56] B.J. Nolletti
Description:
When executing the C# code:

string Sql = "select FTPTime, StoreN from sysinfo;";
OdbcDataAdapter odbcAdapter = new OdbcDataAdapter(Sql, odbcConnectionString);
DataSet ds = new DataSet();
odbcAdapter.Fill(ds);

where FTPTime is of type TIME and the connection string is:
"ODBC;DATABASE=cdreg;UID=cdreg;PWD=<omitted>;DSN=cdreg";

How to repeat:
a small program written in vb6 just downright crashes the ide when I try to do something simmilar.

dim cn as adodb.connection
dim rs as adodb.recordset
dim sql as string

set cn = new adodb.connection
cn.open "ODBC;DATABASE=cdreg;UID=cdreg;PWD=<omitted>;DSN=cdreg"
sql = "select FTPTime from sysinfo;"
set rs = new adodb.recordset
rs.open sql, cn, adopenforwardonly, adlockreadonly  'crashes here

rs.close
set rs = nothing
cn.close
set cn = nothing
[29 Oct 2005 8:03] Vasily Kishkin
Thanks for the bug report. I was able to reproduce the bug. Test case is attached.
[29 Oct 2005 8:04] Vasily Kishkin
Test case

Attachment: 14432.zip (application/x-zip-compressed, text), 5.11 KiB.

[20 Oct 2006 13:11] Peter Leow
I am a new comer to MySQL.

I came across this "Unknown SQL type - 65530" error while trying to send a SQL query from a .NET application to MySQL 5.0.18.

It happened when this statement was fired: "SELECT send_id, phone_no, message from send" where send_id was a primary key. This statement work fine in the MySQL Query Browser.

However, when I removed the send_id which was the primary key from the statement, say "SELECT phone_no, message from send", this time it worked!

But I still needed to retrieve the primary key, how??

So I tried this, "SELECT send_id+'', phone_no, message from send", bingo! it worked.
[17 Oct 2007 20:21] Erica Moss
This was verified fixed in MyODBC 5.1.0
Tested using, VB6 and VB.Net

As a note to the original reporter, you are using a malformed connection string here.  Each clause in the string must be of the form Variable=Value, so there is an error in your first clause "ODBC;".  I'm not sure what purpose this was meant to serve.  You have all of the necessary information between the UID,PWD, and DSN.   

However this was most likely not the source of the problem you were having as Windows seems to  simply strip the bad clause out.