Bug #14310 Database symbolic link isn't detected by server on windows
Submitted: 25 Oct 2005 23:02 Modified: 22 Nov 2005 11:44
Reporter: Tetsuro Ikeda Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:5.0.15 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any

[25 Oct 2005 23:02] Tetsuro Ikeda
Description:
The database symbolic link isn't detected by MySQL 5.0.15-windows-installer distribution, although It worked well with MySQL 5.0.13-win-installer distribution.

How to repeat:
Try the bellow with MySQL 5.0.15-win-installer distribution.

http://dev.mysql.com/doc/refman/5.0/en/windows-symbolic-links.html

You can also find by "show variables" like following:

[MySQL 5.0.15-max-nt]
mysql> select version();
+---------------+
| version()     |
+---------------+
| 5.0.15-nt-max |
+---------------+
1 row in set (0.00 sec)

mysql> show variables like 'have_symlink';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| have_symlink  | NO    |
+---------------+-------+
1 row in set (0.00 sec)

[MySQL 5.0.13-nt]
mysql> select version();
+--------------+
| version()    |
+--------------+
| 5.0.13-rc-nt |
+--------------+
1 row in set (0.00 sec)

mysql> show variables like 'have_symlink';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| have_symlink  | YES   |
+---------------+-------+
1 row in set (0.00 sec)

Suggested fix:
May be a compile option issue? 

-DUSE_SYMDIR
[26 Oct 2005 6:20] Valeriy Kravchuk
Thank you for a bug report. Yes, according to the manual symbolic links should be enabled by default on 5.0.x. This was really true in 5.0.13-rc-nt:

mysql> select version();
+--------------+
| version()    |
+--------------+
| 5.0.13-rc-nt |
+--------------+
1 row in set (0.03 sec)

mysql> show variables like 'have_sym%';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| have_symlink  | YES   |
+---------------+-------+
1 row in set (0.02 sec)

Let me check 5.0.15...
[26 Oct 2005 6:36] Valeriy Kravchuk
And yes, you a right, in 5.0.15 this is not true by default:

mysql> select version();
+-----------+
| version() |
+-----------+
| 5.0.15-nt |
+-----------+
1 row in set (0.03 sec)

mysql> show variables like 'have_sym%';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| have_symlink  | NO    |
+---------------+-------+
1 row in set (0.02 sec)

So, it is either a bug in compilation and packaging process on Windows or documentation should be updated. Verified just as described by reporter on Windows XP.
[3 Nov 2005 16:12] Dave Pullin
I have the same problem on the "without installer" version of 5.0.15.

For me this is a critical problem -- I have to back out of migration to V5 until it is fixed. Is there a by-pass?
[3 Nov 2005 16:24] Dave Pullin
The 5.0.15-nt-max-log version (in without installer package) also has have_symlink NO
[10 Nov 2005 10:30] Paolo Alessandroni
I have tried the windows source standard.

I have added the USE_SYMDIR in all configurations of libmysql, libmysqld, mysys and mysqld projects and recompiled the Release, -nt and -max-nt versions.

After reinstallation of new binaries the 5.0.15-nt-max also has have_symlink set to NO.
[14 Nov 2005 13:23] Carlos Blaster
I´ve tried all stuff, can´t have symlinks working on winXP SP2 with mysqld version 5.0.15 too. Does anyone have a bypass? I use to use symlinks to keep all data in the project directory, I can´t work in other way here.
[22 Nov 2005 10:34] Paolo Alessandroni
The problem still exist in version 5.0.16.

Paolo Alessandroni
[22 Nov 2005 11:44] Miguel Solorzano
Duplicate of bug: http://bugs.mysql.com/bug.php?id=14960