Bug #14078 Crash when trying to log in
Submitted: 17 Oct 2005 17:03 Modified: 26 Oct 2005 22:19
Reporter: jaime pereira Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:1.1 OS:Mac OS X (mac osx 10.4.2)
Assigned to: CPU Architecture:Any

[17 Oct 2005 17:03] jaime pereira
Description:
I just installed the MYSQL administrator program for Mac OSX. When I enter the server fin and click "Connect" the application crashes. The Crash dump is below

Date/Time:      2005-10-17 12:52:08.548 -0400
OS Version:     10.4.2 (Build 8C46)
Report Version: 3

Command: MySQL Administrator
Path:    /Applications/MySQL Administrator.app/Contents/MacOS/MySQL Administrator
Parent:  WindowServer [846]

Version: ??? (1.1.0)

PID:    1910
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   libSystem.B.dylib          	0x900031e8 strlen + 8
1   libSystem.B.dylib          	0x9001f880 sscanf + 88
2   com.mysql.MySQLToolsCommon 	0x100354e0 myx_get_mysql_version + 96
3   com.mysql.MySQLToolsCommon 	0x100355b4 myx_get_mysql_major_version + 24
4   com.mysql.MySQLToolsCommon 	0x10001e50 -[MConnectionPanel(Private) connectionFinished:] + 216
5   com.apple.Foundation       	0x92890760 __NSFireMainThreadPerform + 276
6   com.apple.CoreFoundation   	0x9077c108 __CFRunLoopPerformPerform + 104
7   com.apple.CoreFoundation   	0x9074bc8c __CFRunLoopDoSources0 + 384
8   com.apple.CoreFoundation   	0x9074b1bc __CFRunLoopRun + 452
9   com.apple.CoreFoundation   	0x9074ac3c CFRunLoopRunSpecific + 268
10  com.apple.HIToolbox        	0x93129ac0 RunCurrentEventLoopInMode + 264
11  com.apple.HIToolbox        	0x93129154 ReceiveNextEventCommon + 380
12  com.apple.HIToolbox        	0x93128fc0 BlockUntilNextEventMatchingListInMode + 96
13  com.apple.AppKit           	0x93623e44 _DPSNextEvent + 384
14  com.apple.AppKit           	0x93623b08 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 116
15  com.apple.AppKit           	0x9362006c -[NSApplication run] + 472
16  com.apple.AppKit           	0x937108bc NSApplicationMain + 452
17  com.mysql.Administrator    	0x00005a24 _start + 392 (crt.c:267)
18  com.mysql.Administrator    	0x00005898 start + 48

Thread 1:
0   libSystem.B.dylib          	0x9002ca78 semaphore_wait_signal_trap + 8
...

Thread 0 crashed with PPC Thread State 64:
  srr0: 0x00000000900031e8 srr1: 0x000000000000f030                        vrsave: 0x0000000000000000
    cr: 0x82028242          xer: 0x0000000000000006   lr: 0x000000009001f880  ctr: 0x00000000900031e0
    r0: 0x000000009001f880   r1: 0x00000000bfffe290   r2: 0x0000000000000038   r3: 0x0000000000000000
    r4: 0x00000000100ae024   r5: 0x00000000bfffe468   r6: 0x00000000bfffe46c   r7: 0x00000000ffffffff
    r8: 0x000000006e48476d   r9: 0x0000000000000000  r10: 0x0000000010034a04  r11: 0x00000000a00063fc
   r12: 0x00000000900031e0  r13: 0x0000000000000000  r14: 0x0000000000000001  r15: 0x0000000000000001
   r16: 0x0000000000000000  r17: 0x0000000000000000  r18: 0x0000000000005c07  r19: 0x0000000000000000
   r20: 0x00000000101b0e9a  r21: 0x00000000e9d96b32  r22: 0x0000000000000001  r23: 0x000000000030cf10
   r24: 0x0000000000000000  r25: 0x000000000030cf18  r26: 0x000000000030d028  r27: 0x00000000000007d5
   r28: 0x00000000bfffe2cc  r29: 0x0000000000000000  r30: 0x00000000100ae024  r31: 0x000000009001f830

Binary Images Description:
    0x1000 -    0x54fff com.mysql.Administrator ??? (1.1.0)	/Applications/MySQL Administrator.app/Contents/MacOS/MySQL Administrator
 0x429c000 -  0x42a2fff com.apple.DictionaryServiceComponent 1.0.0	/System/Library/Components/DictionaryService.component/Contents/MacOS/DictionaryService
 0x42f2000 -  0x4453fff com.elgato.mpegsupport EyeTV MPEG Support 1.0.2 (build 28) (1.0.2)	/Library/QuickTime/EyeTV MPEG Support.component/Contents/MacOS/EyeTV MPEG Support
0x10000000 - 0x100d6fff com.mysql.MySQLToolsCommon ??? (1.0)	/Applications/MySQL Administrator.app/Contents/Frameworks/MySQLToolsCommon.framework/Versions/1.0.0/MySQLToolsCommon
...

How to repeat:
1. start app.
2. enter server info
3. click connect
[19 Oct 2005 1:45] jaime pereira
Update OS Version
[19 Oct 2005 14:50] jaime pereira
Complete Crash Report

Attachment: report.txt (text/plain), 17.24 KiB.

[19 Oct 2005 14:52] jaime pereira
change os type
[25 Oct 2005 1:20] Marc Swindle
Was working for me until I upgraded from the 5.0 release candidate to 5.015 (or whatever today's 5.0 release was). Admin crashed with no password. I assumed
that was the problem so I did a mysql_secure_installation and assigned a
password.

It still crashes.

I have deleted the app and all preference files. Does not help.

The error I get is:

EXC_BAD_ACCESS (0x0001)
KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0    strlen + 8
1    sscanf + 88
2    myx_get_mysql_version + 96
3    myx_get_mysql_major_version + 24
4    -[MConnectionPanel(Private) connectionFinished:] + 216
5    __NSFireMainThreadPerform + 276
6    __CFRunLoopPerformPerform + 104
7    __CFRunLoopDoSources0 + 384
8    __CFRunLoopRun + 452
9    CFRunLoopRunSpecific + 268

I also have a crsh log that I can send someone.
I am using Mac OS 10.4.2 and installed todays release of MySql (which is working
fine).
[25 Oct 2005 17:35] Marc Swindle
I got it to work again. I did several things. rebuild permissions, run the daily-monthly logs, optimize system. Not sure that any of that helped. I deleted the plist, the administrator folder. I don't think that helped either. 

THEN, I noticed that the default port for my connection was set to '0'.
I deleted the connection xml file that I think both Query Browser and Administrator use. Maybe that file gets corrupted?

I entered my connection info again, and it worked. To save time, try deleting the connection xml file. When you start up, you should get an empty connection screen.
[26 Oct 2005 22:19] Jorge del Conde
I was unable to reproduce this bug using 10.4 and 1.1
[17 Nov 2005 11:07] Sammi Williams
Hello, I have this bug also. I just downloaded the latest version (1.1) and it crashes as soon as I click connect with any server - localhost, remote, etc.

The crash log is basically identical (strlen, sscanf, MConnectionPanel or whatever).

Please let me know if you need further information.
[17 Nov 2005 11:08] Sammi Williams
By the way, this is on OS X 10.4.3, and affects both versions 1.0 and 1.1 of the MySQL Administrator.