Bug #14041 Migration Toolkit doesn't start
Submitted: 14 Oct 2005 21:54 Modified: 19 Oct 2005 16:53
Reporter: Markus Popp Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S1 (Critical)
Version:1.0.18-rc OS:Microsoft Windows (Windows XP SP1)
Assigned to: CPU Architecture:Any

[14 Oct 2005 21:54] Markus Popp
Description:
Starting Migration Toolkit 1.0.18-rc on my Windows XP SP1 machine, I first get the error message

file .\source\myx_grt_struct.c: line 369: assertion `gstruct != NULL' failed

Clicking this away I get the message:

The GRT environment could not be initialized. Please check your Java installation then try to restart the tool.

Error details:
The function did not return an object. Error Nr. 10003

Shell output: MySQL Generic Runtime Environment 2.0.10 beta

Type 'help' or '?' for help. Type 'quit' to exit the shell.
Error while loading struct definition (10001).
Initializing native loader ...
Initializing Java loader ...
Error initializing Java module loader (10001). Please check the .\java and .\java\lib directories.
Initializing Lua loader ...
Registered 3 builtin modules.
Cannot find module directory ./lua.
Error while loading Lua modules (10001).

How to repeat:
Messages show up immediately after starting Migration Toolkit.
[15 Oct 2005 0:31] MySQL Verification Team
I was unable to repeat the behavior reported.
Did you read the below note in the download page?

http://dev.mysql.com/downloads/migration-toolkit/1.0.html

ATTENTION: Before installing the MySQL Migration Toolkit please download and install the Java 5.0 or 1.4.2 Runtime Environment (JRE) from http://java.sun.com
[15 Oct 2005 0:36] Markus Popp
I've got JRE 1.5.0_04 installed on this machine:

C:>java -version
java version "1.5.0_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)
Java HotSpot(TM) Client VM (build 1.5.0_04-b05, mixed mode, sharing)

Maybe it interferes with something that's quite specific on my PC (it's no fresh installation), so I hoped that the error messages could give you a clue where the error could be found.
[18 Oct 2005 17:44] Markus Popp
This is the first error message, immediately after starting the Migration Toolkit.

Attachment: screenshot1.jpg (image/jpeg, text), 52.88 KiB.

[18 Oct 2005 17:45] Markus Popp
After clicking the first message away, this second message box pops up.

Attachment: screenshot2.jpg (image/jpeg, text), 50.76 KiB.

[18 Oct 2005 17:46] Markus Popp
The JRE 1.5.0 is properly installed on this machine.

Attachment: screenshot3.jpg (image/jpeg, text), 33.28 KiB.

[19 Oct 2005 11:54] Markus Popp
The problem is still there in 1.0.19-rc.
[19 Oct 2005 14:39] Michael G. Zinner
Could you please try the following:

C:\...>grtsh -jvm "C:\Programme\Java\jre1.5.0_02\bin\client\jvm.dll"
MySQL Generic Runtime Environment 2.0.11 beta

Type 'help' or '?' for help. Type 'quit' to exit the shell.

Scanning for struct definitions in ./xml ...
Registered 13 struct definition files.
Initializing Builtin modules...
Initializing Java loader...
Scanning for Java modules in ./java/com/mysql/grt/modules ...
Registered 14 modules.
Initializing Lua loader...
Scanning for Lua plugins in ./lua ...
Registered 11 modules.

/ > print(BaseJava:engineVersion())
"Java 1.5.0_02 Sun Microsystems Inc."
/ >

If this works, please start the MT with the same option.

C:\...>mysqlmigrationtool -jvm "C:\Prgramme\Java\jre1.5.0_02\bin\client\jvm.dll"

Then press F4 to get the X GRT shell and execute the same command as before.
[19 Oct 2005 15:00] Markus Popp
It worked:

D:\Programme\MySQL\MySQL Migration Toolkit 1.0>grtsh -jvm "D:\Programme\Java\jre1.5.0_04\bin\client\jvm.dll"
MySQL Generic Runtime Environment 2.0.11 beta

Type 'help' or '?' for help. Type 'quit' to exit the shell.

Scanning for struct definitions in ./xml ...
Registered 10 struct definition files.
Initializing Builtin modules...
Initializing Java loader...
Scanning for Java modules in ./java/com/mysql/grt/modules ...
Registered 13 modules.
Initializing Lua loader...
Scanning for Lua plugins in ./lua ...
Registered 9 modules.

/ > print(BaseJava:engineVersion())
"Java 1.5.0_04 Sun Microsystems Inc."
/ >
D:\Programme\MySQL\MySQL Migration Toolkit 1.0>mysqlmigrationtool -jvm

... then the Migration Toolkit started.
[19 Oct 2005 15:19] Markus Popp
GRT Shell

Attachment: screenshot.jpg (image/jpeg, text), 65.05 KiB.

[19 Oct 2005 16:53] Michael G. Zinner
It seems that your registry is a bit messed up. Could you check

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.5

and see if the RuntimeLib entry is set to the correct path?

Same for all 1.5.x entries. If there is an entry that points to a wrong file the MT is likely to not come up.
[15 Nov 2005 18:57] James Choi
I got the same problem running it under windows xp sp2.

The problem is that when you use different install path, the application shortcut doesn't point to the right program path.

I just changed the shortcut's program path to point to my custom install path and the program ran just fine.