Bug #13979 InnoDB engine doesn't support FULLTEXT
Submitted: 12 Oct 2005 20:24 Modified: 13 Feb 2012 1:10
Reporter: Ian Gulliver Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S4 (Feature request)
Version:5.0.13 OS:Any (Debian Sarge)
Assigned to: Sunny Bains CPU Architecture:Any
Triage: Needs Triage: D5 (Feature request)

[12 Oct 2005 20:24] Ian Gulliver
Description:
InnoDB doesn't support FULLTEXT indexes.  This is one of the few remaining features present in MyISAM and not in InnoDB, preventing migration.

How to repeat:
CREATE TABLE a (id TEXT, FULLTEXT (id));

CREATE TABLE b (id TEXT, FULLTEXT (id)) ENGINE=InnoDB;

/* ERROR 1214 (HY000): The used table type doesn't support FULLTEXT indexes */

Suggested fix:
Add FULLTEXT support to the InnoDB engine.
[17 Mar 2011 18:44] Valeriy Kravchuk
Bug #60521 was marked as a duplicate of this one.
[17 Mar 2011 18:46] Valeriy Kravchuk
See http://forge.mysql.com/worklog/task.php?id=2559, for example.
[13 Feb 2012 1:10] Sunny Bains
This functionality is part of 5.6.