Bug #1392 On Win, slave leaves one temp file after successf. replicating LOAD DATA INFILE
Submitted: 24 Sep 2003 13:33 Modified: 24 Sep 2003 15:25
Reporter: Guilhem Bichot Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:4.0 OS:Microsoft Windows (windows)
Assigned to: Guilhem Bichot

[24 Sep 2003 13:33] Guilhem Bichot
Description:
see how-to-repeat. Happens only on Windows.

How to repeat:
master:
create table t(a int);
have a file "filename" containing 1 and 1 (2 rows).
load data infile "filename" into table t;
Then on slave, check tmpdir (or slave_load_tmpdir): it contains 1 temporary file, SQL_LOADxxx.info. This file should have been deleted.

Suggested fix:
caused by the fact that Windows requires all handles to be closed before allowing the deletion of a file.
[24 Sep 2003 13:58] Guilhem Bichot
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

ChangeSet@1.1570.1.12, 2003-09-24 22:55:04+02:00, guilhem@mysql.com
Patch tested by our Windows experts.