Bug #1371 ERROR 1030: Got error 134 from table handler
Submitted: 22 Sep 2003 3:38 Modified: 23 Sep 2003 4:28
Reporter: Umar Kathap Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Command-line Clients Severity:S2 (Serious)
Version:3.23.52-1 OS:Linux (Linux 6.2)
Assigned to: CPU Architecture:Any

[22 Sep 2003 3:38] Umar Kathap
When I am trying to insert a record i am getting

"ERROR 1030: Got error 134 from table handler"

The same error I am getting even in select or update for column bug_id 1497.

select bug_id from bugs where bug_id > 1495; giving result as

but select bug_id,groupset from bugs where bug_id > 1495 giving the above 
mentioned error.

Reproducible: Always

Thanks in Advance

How to repeat:
It's happened suddenly so I am unable to give steps for reproducing the same.
But You can guess and resolve the problem by the details given by me.
[23 Sep 2003 4:28] Indrek Siitan
The above error means that your table has become corrupt and you should
repair it using the REPAIR TABLE command.
[23 Sep 2003 4:58] Umar Kathap
Hi Siitan,
  I just droped and restore the table. It's working fine.

[16 Dec 2004 12:48] Rafael Cabral
I think this problem occours because a table had 1 or more rows corrupted. When I repaired a table, MySQL prompt return a following message:

repair | warning  | Number of rows changed from 5685492 to 45727

[25 May 2007 7:08] Cedric Jeanneret
so, seems this is not only when table is corrupted :
line 107 : mysql_query('repair table cache');
line 108 : mysql_query('select time, content from cache where url="http://www.edi-tender.com/MarchesPublics/avis.asp?n=315654"');

->> Got error 134 from storage engine

this table is sometimes crashed, so I added a repair instruction before selecting and inserting...
mysql version:

mysql  Ver 14.12 Distrib 5.0.38, for pc-linux-gnu (x86_64) using readline 5.1
on gentoo 64 2006.1

do you have a solution/idea ?