Bug #1359 date diff not working when givin specific dates
Submitted: 20 Sep 2003 14:03 Modified: 20 Sep 2003 15:27
Reporter: bodybag jones Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:4.0.15, 3.23.56 OS:Microsoft Windows (win32, linux)
Assigned to:

[20 Sep 2003 14:03] bodybag jones
Description:
SELECT (UNIX_TIMESTAMP("2003-10-26 3:00:00")-UNIX_TIMESTAMP("2003-10-25 23:00:00")) AS unterschied FROM std_abrechnung LIMIT 1

result--> unterschied=18000

but should be

result--> unterschied=14400

How to repeat:
see description

Suggested fix:
i dont no
[20 Sep 2003 14:11] bodybag jones
Well,
i just found out that this is the end of daylight saving time.
sorry for the inconvience.
[20 Sep 2003 15:27] Alexander Keremidarski
Not a bug as mentioned by bodybag jones.