Bug #13550 --without-server compilation fails
Submitted: 28 Sep 2005 3:04 Modified: 30 Sep 2005 17:46
Reporter: Luke Hollins Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S2 (Serious)
Version:5.0.13-rc OS:Any (any)
Assigned to: Joerg Bruehe

[28 Sep 2005 3:04] Luke Hollins
Description:
using configure --without-server, completes fine then run make. In mysys on two boxes I get:
if gcc -DDEFAULT_BASEDIR=\"/usr/local\" -DDATADIR="\"/usr/local/var\"" -DDEFAULT_CHARSET_HOME="\"/usr/local\"" -DSHAREDIR="\"/usr/local/share/mysql\"" -DDEFAULT_HOME_ENV=MYSQL_HOME -DDEFAULT_GROUP_SUFFIX_ENV=MYSQL_GROUP_SUFFIX -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../include -I.    -O3 -DDBUG_OFF    -MT mf_keycache.o -MD -MP -MF ".deps/mf_keycache.Tpo" -c -o mf_keycache.o mf_keycache.c; \
then mv -f ".deps/mf_keycache.Tpo" ".deps/mf_keycache.Po"; else rm -f ".deps/mf_keycache.Tpo"; exit 1; fi
mf_keycache.c: In function `resize_key_cache':
mf_keycache.c:496: error: `my_thread_var' undeclared (first use in this function)
mf_keycache.c:496: error: (Each undeclared identifier is reported only once
mf_keycache.c:496: error: for each function it appears in.)

How to repeat:
run configure --without-server then make

Suggested fix:
make --without-server imply --enable-thread-safe-client. if i just run configure on either system it builds fine. If I use --without-server and --enable-thread-safe-client it works as well.
[30 Sep 2005 17:46] Joerg Bruehe
Duplicate of bug#11680,
the different symptoms are just due to intermediate work on it
(see the entries in bug#11680).

Fix is pushed, will be included in 5.0.14-rc.
[30 Sep 2005 18:05] Paul Dubois
Noted in 5.0.14 changelog.