Bug #13540 Returns certain Double Datatypes values with #Deleted in Access
Submitted: 27 Sep 2005 20:17 Modified: 2 Aug 2007 14:08
Reporter: Peter Mo Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.11.00-2 OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any
Tags: ODBC5-RC

[27 Sep 2005 20:17] Peter Mo
Description:
Certain values will show up as #Deleted in MS Access.

How to repeat:
Created a table with one column as double(4,1)
Enter any of the following values:
580.2
610.2
640.2
660.2

Any other values would show up correctly, but these will not.

Suggested fix:
There is no workaround, that's why it's a severe bug.
[27 Sep 2005 20:49] Peter Mo
I forgot to mentioned that the column has to be a primary key.
[27 Sep 2005 21:23] Peter Mo
Actually, instead of being the Primary key.
I found out that as long as it's the first column in a table, it will happen.
[27 Sep 2005 22:11] Miguel Solorzano
Could you please read the below Manual's item:

http://dev.mysql.com/doc/mysql/en/deleted-problem.html

if you are not able, please submit the table creation command.

Thanks in advance.
[27 Sep 2005 22:23] Peter Mo
Yes, I've already looked at that Bug reference.
I've tried just about everything for about a week now.
Here's the create table script:

CREATE TABLE `test`.`test_table` (
  `id` DOUBLE(4,1) NOT NULL,
  PRIMARY KEY(`id`)
)
ENGINE = InnoDB;

This is a different problem than any other bugs.
[27 Sep 2005 22:24] Peter Mo
Just wanted to note that I'm using the latest version of everything in MS Access and MYSQL as of today Sept. 27, 2005.
[27 Sep 2005 23:50] Peter Mo
I realized that it is in fact because of a primary or unique key on the column.
My temporary work around is just to drop the primary key, but then users will be able to add duplicate entries if not careful enough.  Hopefully developers will fix this soon.  Thanks.
[28 Sep 2005 3:17] Miguel Solorzano
Verified with Access 2003.
[27 Apr 2007 18:21] Jim Winstead
Bug #18123 has been marked as a duplicate of this bug.
[2 Aug 2007 14:07] Miguel Solorzano
Access Double data type

Attachment: access-double.png (image/png, text), 18.35 KiB.

[2 Aug 2007 14:08] Miguel Solorzano
Can't repeat anymore with version 3.51.17 (see attached picture).