Bug #13383 Server will not start with InnoDB lines uncommented
Submitted: 21 Sep 2005 16:31 Modified: 21 Sep 2005 21:16
Reporter: Doug Hunting Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version: 5.0.12-beta-max-log OS:Linux (Linux 2.6.10)
Assigned to: Miguel Solorzano CPU Architecture:Any

[21 Sep 2005 16:31] Doug Hunting
Description:
I used the my-large.cnf file in /usr/local/mysql/support-files for my /etc/my.cnf config file. I uncommented the lines under where it says...# Uncomment the following if you are using InnoDB tables. Tried to start the server and the server hung and then crashed... Leaving lines commented out doesn't cause this error

How to repeat:
1.) Bring down the server
2.) Edit /usr/local/mysql/support-files/my-large.cnf
3.) Uncomment the lines under "# Uncomment the following if you are using InnoDB tables"
4.) Save file as /etc/my.cnf
5.) Start server using /usr/local/mysql/bin/mysqld_safe --user=mysql --default-table-type=InnoDB &
6.) Attempt to run /usr/local/mysql/bin/mysql
7.) Server never restarts and eventually crashes
[21 Sep 2005 16:44] Miguel Solorzano
Could you please show us the lines printed on the log-error file
and how you uncommented these lines.

Thanks in advance.
[21 Sep 2005 19:32] Doug Hunting
These are the lines that I uncommented :

#innodb_data_home_dir = /usr/local/mysql/data/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/mysql/data/
#innodb_log_arch_dir = /usr/local/mysql/data/
#innodb_buffer_pool_size = 256M
#innodb_additional_mem_pool_size = 20M
#innodb_log_file_size = 64M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

Here are the results of the [server].err file:

050921 02:20:43  mysqld started
050921  2:20:43  InnoDB: Error: cannot allocate 268451840 bytes of
InnoDB: memory with malloc! Total allocated memory
InnoDB: by InnoDB 25922024 bytes. Operating system errno: 12
InnoDB: Check if you should increase the swap file or
InnoDB: ulimits of your operating system.
InnoDB: On FreeBSD check you have compiled the OS with
InnoDB: a big enough maximum process size.
InnoDB: Note that in most 32-bit computers the process
InnoDB: memory space is limited to 2 GB or 4 GB.
InnoDB: We keep retrying the allocation for 60 seconds...
InnoDB: Fatal error: cannot allocate the memory for the buffer pool
050921  2:21:43 [ERROR] Can't init databases
050921  2:21:43 [ERROR] Aborting

050921  2:21:43 [Note] /usr/local/mysql/bin/mysqld: Shutdown complete

050921 02:21:43  mysqld ended
[21 Sep 2005 20:14] Miguel Solorzano
According the log-error you are out of the resources and InnoDB
engines has aborted. If actually that is the reason, could you
please change the values of the buffer for more adequate ones
for your hardware.
[21 Sep 2005 21:16] Miguel Solorzano
Thank you for the feedback.