Bug #13355 SQL State: HYC00 - Recieved when importing data w/ Micrsoft Log Parser
Submitted: 20 Sep 2005 17:06 Modified: 30 May 2013 7:23
Reporter: [ name withheld ] Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.00 beta OS:Microsoft Windows (Windows XP Pro)
Assigned to: CPU Architecture:Any

[20 Sep 2005 17:06] [ name withheld ]
Description:
Using Micrsoft Log Parser program with the following command line code:

C:\Program Files\Log Parser 2.2>logparser "select *, sourcename from system TO tblevents" -i:evt -o:sql -server:localhost -database:event_id -username
:root -password:password -driver:"MySQL Connector/ODBC v5"

This is what it gives me:

Task aborted.
Error setting concurrency
  SQL State:     HYC00
  Native Error:  0
  Error Message: [MySQL][MyODBC 05.00.0000][HYC00] Optional feature not
  implemented

Statistics:
-----------
Elements processed: 0
Elements output:    0
Execution time:     0.03 seconds

How to repeat:
Install MyODBC 5 Alpha on an Windows XP Professional machine.  Run with it with the latest stable version of MySQL and repeat the line of code in my description.  

Suggested fix:
[21 Sep 2005 10:08] Vasily Kishkin
I was able to reproduce it on v5. MyODBC 3.51 works fine. Thanks for bug report.
[26 Sep 2005 17:14] [ name withheld ]
MyODBC 3.51 does not exhibit this error, but has other bugs (which have been reported) that prevent me from using it.  The bug number is 8559.
[28 Nov 2006 21:21] Jess Balint
The ODBC v3 param SQL_MAX_CONCURRENT_ACTIVITIES was set to 0, but we have changed it to 1 for now.

However, there is still missing support for this utility:

C:\Program Files\Log Parser 2.2>LogParser "select * from Security to tblsec" -o:
sql -server:localhost -database:test -username:root -driver:"MySQL Connector/ODB
C v5"
Task aborted.
Error setting cursor type
  SQL State:     HYC00
  Native Error:  0
  Error Message: [MySQL][MyODBC 5.00.10] SQL_CURSOR_DYNAMIC not supported.

Statistics:
-----------
Elements processed: 0
Elements output:    0
Execution time:     0.06 seconds
[29 Oct 2007 14:41] Susanne Ebrecht
Hi,

this works fine with MyODBC version 5.1. Please try it.

Thank you for trusting MySQL.

Kind Regards,

Susanne
[30 Nov 2007 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[30 May 2013 7:23] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.