Bug #13208 .edit and .update fail completely with VB6/DAO 3.51 or DAO 3.60
Submitted: 15 Sep 2005 1:42 Modified: 15 Sep 2005 3:44
Reporter: Michael Baldwin Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:most recent OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[15 Sep 2005 1:42] Michael Baldwin
Description:
I'm using VB6 with DAO and MySQL under Windows XP via ODBCdirect. I've found that I can execute queries and read recordsets, but that calling Recordset.Edit or Recordset.Update fail completely.

DAO 3.51 >> on Recordset.Update reports that it can't update the recordset because something else is accessing it at the same time (which it isn't). It passed the Recordset.Edit line just fine.

DAO 3.60 >> on Recordset.Edit the application hangs.

I know a lot of people have found that DAO works more reliably with MySQL than other technologies...but I still can't get a simple Update to work (unless it's an SQL "UPDATE..." query)

How to repeat:
The code is simple!

' Let the user select the MySQL database connection from the ODBC prompt. My connection has all the default options--I only filled out server, password, etc
    Set db = DBEngine.OpenDatabase("", dbDriverPrompt, False)

    Set rs = db.OpenRecordset("data")
                rs.Edit
                rs!local = FID
                rs.Update
[15 Sep 2005 3:44] Jorge del Conde
duplicate of 13207