Bug #13194 Lost connection to database when attempting to create stored procedure
Submitted: 14 Sep 2005 18:07 Modified: 14 Sep 2005 22:15
Reporter: Laurie Pollack Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server Severity:S1 (Critical)
Version:QB 5.0.12 OS:Windows (Windows XP)
Assigned to: CPU Architecture:Any

[14 Sep 2005 18:07] Laurie Pollack
After installing MySQL 5.0.12, Query Browser no longer sees the stored

This may sound similar to an existing bug, but there is more:
In addition to this, I am unable to create a new stored procedure,
either in Query Browser or in Administrator.
When I attempt to do so, it loses connection to the database AND
the database will STOP and need to be restarted.
I also created a brand new database, thinking that the problem was
corruption in my database, however it happened in the brand new database too.
I was able to successfully create tables, both interactively and with a script:
just not stored procedures.
I installed the latest versions of Query Browser and Administrator, thinking that was the problem: but it wasn't.
I have tried using different combinations of delimiters, but nothing works. 

Note that in MySQL 5.0.7: everything worked fine, I could both see,
and create/update stored procedures fine both in the query window, AND with a script. 

To get this to work once again, I will need to reinstall/downgrade to the previous version of the database.

How to repeat:
Install latest version of MySQL essentials, query browser and administrator.
Then in either query browser or administrator, click on "create stored procedure"
and between the begin and end tags, type anything. 
The program will get to around "22% done"; then Windows will report an error and that the database will have to close. After it closes, you will find that the database has stopped and you will need to restart it.
[14 Sep 2005 19:01] MySQL Verification Team
It is the 5.0.2 a fresh install, not upgrade over an older 5.0.XX version?
If yes most probably it is a bug already reported, a clean fresh install
and importing the older data have resolved the issue. Also please try
for to create an SP using the mysql.exe client and verify if you get
the server crash too.

Thanks in advance.
[14 Sep 2005 21:25] Laurie Pollack
For more information on this bug: it displayed the following data: I hope this will help:

szAppName : mysqld-nt.exe     szAppVer :     szModName : mysqld-nt.exe
szModVer : 
    offset : 0013

Then I clicked on "technical info about this error" and was directed to a folder in my documents and settings, which contained the two following text files:
and two other files: I pasted in the short text of the text files: the other
were NOT in text, but I would be glad to attach all of them  in an email if that will help.

Note that:  this was the NEWEST version I had installed, over the top of
an older version (the latter of which formerly worked): should I instead,
de-install the previous version? Would that resolve the issue? 


Text of the two text files: appcomp.txt and manifest.txt:

<?xml version="1.0" encoding="UTF-16"?>
    <MATCHING_FILE NAME="comp-err.exe" SIZE="1171456" CHECKSUM="0x4EFF9AD1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 08:16:52" UPTO_LINK_DATE="07/27/2005 08:16:52" />
    <MATCHING_FILE NAME="libmySQL.dll" SIZE="1449984" CHECKSUM="0x4E4F468D" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x60000" LINK_DATE="08/30/2005 10:56:45" UPTO_LINK_DATE="08/30/2005 10:56:45" />
    <MATCHING_FILE NAME="myisamchk.exe" SIZE="1409024" CHECKSUM="0xCEE5CDC5" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:33" UPTO_LINK_DATE="08/30/2005 10:57:33" />
    <MATCHING_FILE NAME="myisamlog.exe" SIZE="1323008" CHECKSUM="0x1754E132" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:34" UPTO_LINK_DATE="08/30/2005 10:57:34" />
    <MATCHING_FILE NAME="myisampack.exe" SIZE="1331200" CHECKSUM="0x7D34DBD8" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:36" UPTO_LINK_DATE="08/30/2005 10:57:36" />
    <MATCHING_FILE NAME="myisam_ftdump.exe" SIZE="1298432" CHECKSUM="0xF22EA4C4" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 09:55:26" UPTO_LINK_DATE="08/30/2005 09:55:26" />
    <MATCHING_FILE NAME="mysql.exe" SIZE="1507429" CHECKSUM="0xEB82C42F" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:45" UPTO_LINK_DATE="08/30/2005 10:57:45" />
    <MATCHING_FILE NAME="mysqladmin.exe" SIZE="1417216" CHECKSUM="0x57AB7CA4" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:47" UPTO_LINK_DATE="08/30/2005 10:57:47" />
    <MATCHING_FILE NAME="mysqlbinlog.exe" SIZE="1433600" CHECKSUM="0xA1868691" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:48" UPTO_LINK_DATE="08/30/2005 10:57:48" />
    <MATCHING_FILE NAME="mysqlcheck.exe" SIZE="1404928" CHECKSUM="0x3B2C6403" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:49" UPTO_LINK_DATE="08/30/2005 10:57:49" />
    <MATCHING_FILE NAME="mysqld-debug.exe" SIZE="6594660" CHECKSUM="0xAB17D6AA" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 09:19:04" UPTO_LINK_DATE="07/27/2005 09:19:04" />
    <MATCHING_FILE NAME="mysqld-max-nt.exe" SIZE="4571136" CHECKSUM="0x62D49DBC" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 09:12:40" UPTO_LINK_DATE="07/27/2005 09:12:40" />
    <MATCHING_FILE NAME="mysqld-max.exe" SIZE="4567040" CHECKSUM="0x98E63E59" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 09:09:18" UPTO_LINK_DATE="07/27/2005 09:09:18" />
    <MATCHING_FILE NAME="mysqld-nt.exe" SIZE="4100096" CHECKSUM="0x31A376FD" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:28:31" UPTO_LINK_DATE="08/30/2005 10:28:31" />
    <MATCHING_FILE NAME="mysqld.exe" SIZE="4096000" CHECKSUM="0x81ECAAC6" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:13:59" UPTO_LINK_DATE="08/30/2005 10:13:59" />
    <MATCHING_FILE NAME="mysqldump.exe" SIZE="1437696" CHECKSUM="0x7B2FF410" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:52" UPTO_LINK_DATE="08/30/2005 10:57:52" />
    <MATCHING_FILE NAME="mysqlimport.exe" SIZE="1404928" CHECKSUM="0x68A2B76D" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:53" UPTO_LINK_DATE="08/30/2005 10:57:53" />
    <MATCHING_FILE NAME="MySQLInstanceConfig.exe" SIZE="1524224" CHECKSUM="0xED2AB529" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="06/19/1992 22:22:17" UPTO_LINK_DATE="06/19/1992 22:22:17" />
    <MATCHING_FILE NAME="mysqlshow.exe" SIZE="1409024" CHECKSUM="0xA6432EA0" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:57:54" UPTO_LINK_DATE="08/30/2005 10:57:54" />
    <MATCHING_FILE NAME="mysqltest.exe" SIZE="1499136" CHECKSUM="0xAE24526F" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 09:59:40" UPTO_LINK_DATE="07/27/2005 09:59:40" />
    <MATCHING_FILE NAME="mysql_client_test.exe" SIZE="1773568" CHECKSUM="0xBDDF874" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 09:31:50" UPTO_LINK_DATE="07/27/2005 09:31:50" />
    <MATCHING_FILE NAME="my_print_defaults.exe" SIZE="1171456" CHECKSUM="0xC5A3463" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 09:54:39" UPTO_LINK_DATE="08/30/2005 09:54:39" />
    <MATCHING_FILE NAME="perror.exe" SIZE="1150976" CHECKSUM="0x2C2D3539" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="08/30/2005 10:43:52" UPTO_LINK_DATE="08/30/2005 10:43:52" />
    <MATCHING_FILE NAME="replace.exe" SIZE="155648" CHECKSUM="0xD8DD8EA5" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="07/27/2005 08:48:10" UPTO_LINK_DATE="07/27/2005 08:48:10" />
    <MATCHING_FILE NAME="kernel32.dll" SIZE="983552" CHECKSUM="0x4CE79457" BIN_FILE_VERSION="5.1.2600.2180" BIN_PRODUCT_VERSION="5.1.2600.2180" PRODUCT_VERSION="5.1.2600.2180" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFF848" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.2180" UPTO_BIN_PRODUCT_VERSION="5.1.2600.2180" LINK_DATE="08/04/2004 07:56:36" UPTO_LINK_DATE="08/04/2004 07:56:36" VER_LANGUAGE="English (United States) [0x409]" />


UI LCID=1033
DigPidRegPath=HKLM\Software\Microsoft\Windows NT\CurrentVersion\DigitalProductId
ErrorText=If you were in the middle of something, the information you were working on might be lost.
[14 Sep 2005 22:15] MySQL Verification Team
Quoting your last note:

Note that:  this was the NEWEST version I had installed, over the top of
an older version (the latter of which formerly worked): should I instead,
de-install the previous version? Would that resolve the issue? 

Then it is the behavior reported in bug:


The best way for to resolve your issue dump your data and then with
a clean fresh install of 5.0.12 import the data.
[15 Sep 2005 14:03] Laurie Pollack
When I went into Control Panel in Windows: I did notice TWO instances of MySQL Server 5.0, so it may well be that I have some earlier versions of files
that are causing the problem. 

I'm going to de-install all MySQL elements totally, THEN install the latest
versions, and see if this fixes the problem.

Fortunately I have backup scripts for my databases and procedures. (The MySQL Administrator backup does NOT backup procedures: just tables and table data). 

[15 Sep 2005 15:15] Laurie Pollack

The problem was that: I had loaded the newer version of MySQL on top
of the old.

I deleted ALL MySQL via Control Panel. Then deleted the MySQL folder on
C:\Program files. (I had backed up my database via scripts to create the database and build the tables, and procedures). (If you are in the same situation
and are going to do this: please back up your database. Also please back it up BEFORE you install a new version of MySQL).

Once I did that, I reinstalled everything fresh:

Then ran the two scripts from the command line:
They both ran correctly: my stored procedures now appear in the Query
Browser, and I could run it.