Bug #13048 maxQuerySizeToLog is not applied
Submitted: 7 Sep 2005 19:43 Modified: 22 Nov 2005 21:17
Reporter: Quartz 12h Email Updates:
Status: Closed Impact on me:
Category:Connector / J Severity:S3 (Non-critical)
Version:3.1.7+ OS:
Assigned to: Mark Matthews CPU Architecture:Any

[7 Sep 2005 19:43] Quartz 12h
My url defines the SQL string length to profile, but it gets truncated to ~1023 chars anyway, even if the default seams to be 2048 and I asked 20480.

tested on 3.1.7 and 3.1.10 and found on both.

How to repeat:
create long SQL statement and try to profile them.
[11 Sep 2005 23:07] John Bradford
I was able to reproduce the problem using the attached Java code and table.  I tried several different values for maxQuerySizeToLog: 500, 1500, 2048, and 20480.  I even tried letting it default.  In all cases the SQL statement was truncated in the exact same spot.  I was using the 3.1.10 connector.
[11 Sep 2005 23:08] John Bradford
Files used by John Bradford

Attachment: Bug13048.zip (application/x-zip-compressed, text), 21.40 KiB.

[22 Nov 2005 21:17] Mark Matthews
Fixed for 3.1.12 and 5.0.0, see nightly snapshot build after 00:00 GMT Nov 23, or pull from current subversion repository (sources) at http://svn.mysql.com/svnpublic/connector-j/branches/branch_3_1

Thanks for the bug report!