Bug #12917 The --defaults-extra-file option is ignored by the 5.0 client binaries
Submitted: 31 Aug 2005 18:13 Modified: 9 Mar 2007 13:12
Reporter: Hartmut Holzgraefe Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S2 (Serious)
Version:5.0, 4.1, 5.1, 5.2 OS:Linux (linux)
Assigned to: CPU Architecture:Any
Triage: D4 (Minor)

[31 Aug 2005 18:13] Hartmut Holzgraefe
Description:
mysql and mysqldump from 5.0 ignore any settings from option files specified with --defaults-extra-file= option

--defaults-file, $MYSQL_HOME/my.cnf, ~/.my.cnf are processed just fine as expected,
only --defaults-extra-file seems to be broken

How to repeat:
create an option file like this:
 
  # options.ini
  [mysql]
  user=nonexistant_user
  password=foobar

and try to connect to the database using

  mysql --defaults-extra-file=options.ini mysql

this should fail with

  ERROR 1044 (42000): Access denied for user 'nonexistant_user'@'localhost' to database 'mysql'

but it will either succeed or will show a different user name in the error message, depending on your default privileges. Other options put in such an extra file are ignored, too. I tried to put 

  [mysqldump]
  no-data

into it for example but this didn't work either

Suggested fix:
restore --defaults-extra-file functionality as it was in 4.1 and before
[1 Sep 2005 8:38] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/29156
[9 Sep 2005 7:53] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/29549
[12 Sep 2005 11:24] Ramil Kalimullin
fixed in 5.0.13
[14 Sep 2005 0:24] Paul Dubois
Noted in 5.0.13 changelog.
[9 Mar 2007 13:14] Sveta Smirnova
Bug #19611 was marked as duplicate of this one