Bug #12881 ndbd crashes starting
Submitted: 30 Aug 2005 15:05 Modified: 30 Aug 2005 16:51
Reporter: Quim Calpe Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version:5.0.7 OS:Linux (Debian etch)
Assigned to: CPU Architecture:Any

[30 Aug 2005 15:05] Quim Calpe
Cluster setup: 2 MGM nodes, 2 NDB nodes, 2 MySQL API nodes.

One of the NDB nodes refuses to start the ndbd service with error:
>Date/Time: Tuesday 30 August 2005 - 16:58:30
>Type of error: error
>Message: Internal program error (failed ndbrequire)
>Fault ID: 2341
>Problem data: Dbdict.cpp
>Object of reference: DBDICT (Line: 1053) 0x0000000a
>ProgramName: ndbd
>ProcessID: 3068
>TraceFile: /var/lib/mysql/ndb_4_trace.log.12
>Version 5.0.7 (beta)

Tried shutting down cleanly from ndb_mgm and rebooting the system without success.

How to repeat:
No idea, problem began after a crash doing several "ALTER TABLE"...

Suggested fix:
[30 Aug 2005 15:17] Jonathan Miller
You might try the latest release. Also it would help if you could attach the >TraceFile: /var/lib/mysql/ndb_4_trace.log.12
[30 Aug 2005 15:24] Quim Calpe
Trace file

Attachment: ndb_4_trace.log.12 (application/octet-stream, text), 122.20 KiB.

[30 Aug 2005 15:25] Quim Calpe
I'm stuck with 5.0.7 with debian testing (without losing the apt-get goodies...)
[30 Aug 2005 16:08] Quim Calpe
Solved purging with "ndbd --initial" on the affected node