Bug #12876 The query browser doesn't display chinese character correctly
Submitted: 30 Aug 2005 11:58 Modified: 28 Sep 2005 13:09
Reporter: [ name withheld ] Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.14 OS:Microsoft Windows (winxp simplifed chinese)
Assigned to: Mike Lischke CPU Architecture:Any

[30 Aug 2005 11:58] [ name withheld ]
Description:
I open a database script in query browser,the script include insert clause,the content to be inserted have chinese characters. after the script be opened,the chinese character display mess-up.  I quit the query browser, use the notepad open the script and save the file as utf8 format,  load it into query brower again, the chinese still can't be dispaly correctly.  when I move the cursor into the  scope of chinese characters and one click, the query browser abend.  If I ignore the display problem and never move the cursor into the scope of chinese characters and one click,directly execute the script,the script run correctly. I use the select clause to find the data insert into the table, the result display correctly,the chinese characters can be display perfectly in the query browser.

How to repeat:
mysql server version 4.1.14,the database default encode method is set to be utf8. 
query browser 1.1.14. 
create an script encode in ntf8, the script should use insert clause insert some chinese content to table. you will find the problem.

Suggested fix:
I'm not a professional ,but I real hope the query brower and database can support multi-language  perfectly.
[30 Aug 2005 12:01] [ name withheld ]
the script I used

Attachment: 2bookshop.sql (text/plain), 6.81 KiB.

[30 Aug 2005 12:06] [ name withheld ]
in the howto repeat comment, I wrote ntf8 to ntf8,it should be utf8.
[31 Aug 2005 6:32] Jorge del Conde
Thanks for your bug report.  I was able to reproduce this with the attached sql file
[15 Sep 2005 5:11] Thomas Liao
Although I am a beginner in using MySQL database, and the "mysqlcc"
seems a good tool for me to use. But because you don't support
"mysqlcc" any more, and MySQL Query Browser has online help that can
help me to find my error quickly. So I hope I can transfer from
"mysqlcc" to MySQL Query Broswer. Thanks.
[28 Sep 2005 13:09] Mike Lischke
I tried the script as well and cannot see any problem with it. It loads immediately (as utf-8) without converting it first and I executed it without trouble. The data is entered to into the tables and shows fine in the result sets. So I assume this has been fixed in conjunction with another problem Please try the next version once it is published and reopen this bug report with a detail step by step description if the bug is not fixed for you.

Mike