Bug #12802 smalldatetime to datetime nullified to "zero" values.
Submitted: 25 Aug 2005 12:39 Modified: 21 Nov 2005 18:04
Reporter: Scott Hamm Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S1 (Critical)
Version:1.0.14rc OS:Microsoft Windows (Windows XP)
Assigned to: Bugs System CPU Architecture:Any

[25 Aug 2005 12:39] Scott Hamm
Description:
Tried to migrate MS SQL database into MySQL using Migration Toolkit with massive smalldatetime data.  They were converted into "zero" values.

How to repeat:
MS SQL 'QA' Table:

ID int IDENTITY(1,1) not null,
KeyDate smalldatetime null

1  2005-01-01 00:00:00

Executed Migration program (everything to default)

MySQL 'QA' Table:

ID int auto_increment not null,
KeyDate datetime not null

1  0000-00-00 00:00:00
[30 Aug 2005 21:18] Jorge del Conde
I was unable to reporduce this problem using 1.0.15

Can you please send me your MDB file so that I can try and reproduce this bug ?

Thanks!
[2 Sep 2005 17:14] Scott Hamm
MDB file uploaded for developer only.
[2 Sep 2005 17:27] Jorge del Conde
Hi!

I don't see the private MDB file, can you please double-check that you uploaded it correctly ?

Thanks!
[2 Sep 2005 17:30] Scott Hamm
Send me your email address and I will email you directly.
[2 Sep 2005 20:32] Jorge del Conde
Scott, can you please attatch the file to this bug report and put the option so that only mysql developers can access the file ?

Thanks!
[2 Sep 2005 20:33] Jorge del Conde
If by any chance the size of your MDB file is greater than our allowed limit, please email me a copy to jorge@mysql.com

thanks!
[6 Sep 2005 13:32] Scott Hamm
Just now found out that my company's intranet temporarily disabled any outgoing attachments.
[13 Sep 2005 22:02] Jorge del Conde
Hi Scott,

I didn't receive the MDB email.  Can you please send it again ?

Thanks!
[26 Sep 2005 9:42] Gregor Schreier
i have the same problem with 1.0.18rc - its a mssql 2000 database and all smalldatetime values will get  ""
[26 Sep 2005 12:11] Scott Hamm
Can you or did you send the mdb file to this bug list?

I am unable to send any executable files out of my company's Intranet.
[27 Sep 2005 7:24] Gregor Schreier
mssql has no mdb ...

so you need the databasefile ? - if so, i can create one and send it
[27 Sep 2005 11:20] Scott Hamm
That will be greatly appreciated.
[27 Sep 2005 12:59] Gregor Schreier
"Only registered developers and the original submitter are allowed to attach files to the bug." - so maybe i can send it to Jorge by  email ?
but without an email-address....
[26 Oct 2005 21:55] Jorge del Conde
Hi!

You can attatch the file to this bug report and select the option where the files are only available to mysql developers.  Otherwise, you can send it to me via email to jorge@mysql.com.

Thanks a lot!
[31 Oct 2005 18:57] Scott Hamm
Looks like version 1.0.20rc got this bug fixed! 

Thanks!