Bug #12599 MySql and MyODBC
Submitted: 16 Aug 2005 13:23 Modified: 22 Aug 2005 9:07
Reporter: Maroun Merheb Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version: OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[16 Aug 2005 13:23] Maroun Merheb
Description:
First Of All I worked with The MyOdbc 3.51 and MySql 3.4.0.3 ,it had no major
problems,then due to the limitation of MySql 4 to subqueries i Upgrade it to
MySql 3.4.1 and I had a problem with the precision in decimal and floats,ect,..
After that I Upgrade it to MySql 3.5.0.3 .
I can not open a recordset outside the
mysql
database,It gives the error multiple step errors

What is the resolution of this problem
                                                                    Maroun

How to repeat:
Download MySql 5.0.3 and MyOdbc 3.51 (the latest)
Create a database db1 and a table tt1 in it .

Open a vb project that support ADO.

and run the following code

Dim Conn as new adodb.connection
Dim Rs as new adodb.Recordset

conn.open "Driver={MySql ODBC 3.51
Driver};Server=localhost;Database=db1;UId=root;pwd="

rs.open "Select * From tt1",Conn,adopenstatic,adlockPessimistic
[19 Aug 2005 8:13] Vasily Kishkin
Sorry. I was not able to reproduce the bug. Could you please provide your test case ?
[22 Aug 2005 9:07] Vasily Kishkin
This bug report is duplicated. See http://bugs.mysql.com/bug.php?id=12515